Update is causing huge slow down in boot and application start since a week ago

I am on EndevourOS KDE with a new laptop for only a couple of weeks and all worked well for me since a week ago. Since then boot takes minutes with a long stall between grub and seeing the login screen appear. I can log in normally but it takes a long time for the KDE environment to load. Dolphin takes a minute to start every time. It is all just slow with no indicator why.

So far I just reverted with Timeshift to before the updates and hoped the issue would get resolved. But it has been a week and not sure how to figure out what is causing my issues. I can’t see other reports of this. Please help

What packages got updated and what boot message is shown, when boot is stalling?

Also: please give us your hardware information.

have you checked

sudo systemd-analyze blame
sudo systemd-analyze critical-chain
sudo journalctl -b0 -p4
1 Like


  • Run dolphin from a terminal and see if it gives any useful messages.

  • Run a physical health check on the drive, to rule out hardware failure - smart etc. Boot off live media and fsck the disk.

  • Check your blkids in fstab.

Press e on the boot menu entry to edit it.
Remove quiet from the boot parameters.
Press Ctrl-X to boot.

See it the boot message reveals something about where there is a “bottleneck” in the boot process.

1 Like

Take a look here regarding slow application start due to xdg-desktop-portal-gnome, xdg-desktop-portal-kde, etc:

Please see:


The xdg-desktop-portal service is not on status failed like in the posts shown. But they don’t really give a clear indicator on how to check or fix the issue, just that people are having problems. But with even login being slow I am not sure this could be it for my issue

running systemd-analyze shows no single thing that takes very long and it does not show me why normal application launches are taking minutes now. Starting an application like dolphin from terminal shows no problem, but just takes long like mentioned.

journalctl I believe shows what is causing my issue. systemd keeps trying and failing to run services for upower.server and plasma-powerdevil.service. repeating timeouts constantly. But trying to just stop those services via systemctl stop is not helping and can’t find anything online about it.

And it can’t be a hardware problem because if I switch back to before the updates via Timeshift, all works normal. But with like 300 packages updated in that week, I don’t know how to figure out what is causing my problems

1 Like

ok by setting my arch mirrors to a specific date I could narrow down the updates that happened on which my problems are starting:

extra/adwaita-cursors                43-2         44.0-1         0,00 MiB
extra/adwaita-icon-theme             43-2         44.0-1        -3,18 MiB
core/ca-certificates-mozilla         3.89-1       3.89.1-1       0,01 MiB
extra/dkms                           3.0.10-1     3.0.11-1       0,00 MiB
endeavouros/eos-bash-shared          23-13        23-14          0,00 MiB
endeavouros/eos-translations         23-21        23-22          0,00 MiB
extra/gjs                            2:1.74.2-1   2:1.76.0-1     0,01 MiB
extra/gobject-introspection          1.76.1-2     1.76.1-3       0,01 MiB
extra/gobject-introspection-runtime  1.76.1-2     1.76.1-3       0,00 MiB
extra/gsl                            2.7.1-1      2.7.1-3       -0,36 MiB
extra/kio-extras                     23.04.0-1    23.04.0-2      0,00 MiB
multilib/lib32-nss                   3.89-1       3.89.1-1       0,02 MiB
extra/libgirepository                1.76.1-2     1.76.1-3       0,00 MiB
extra/libimobiledevice               1.3.0-7      1.3.0-8        0,00 MiB
extra/libplist                       2.2.0-7      2.3.0-1        0,06 MiB
extra/libusbmuxd                     2.0.2-1      2.0.2-2       -0,02 MiB
core/nss                             3.89-1       3.89.1-1       0,00 MiB
core/perl                            5.36.0-3     5.36.1-1      -0,09 MiB
extra/solid                          5.105.0-1    5.105.0-2      0,00 MiB
extra/step                           23.04.0-1    23.04.0-2      0,02 MiB
extra/usbmuxd                        1.1.1-2      1.1.1-3        0,00 MiB
extra/webkit2gtk                     2.40.1-1     2.40.1-2       0,19 MiB
endeavouros/welcome                  3.60-1       3.62-1         0,00 MiB
extra/zenity                         3.44.0-3     3.44.1-1       0,00 MiB

I know one of these package changes is what is starting the problem. But I don’t know most of these and which of them could be a problem from before login to every application launch

  Kernel: 6.3.1-arch1-1 arch: x86_64 bits: 64 Desktop: KDE Plasma v: 5.27.4
    Distro: EndeavourOS
  Type: Detachable System: ASUSTeK product: ROG Flow Z13 GZ301VIC_GZ301VIC
    v: 1.0 serial: R1NRKD019103048
  Mobo: ASUSTeK model: GZ301VIC v: 1.0 serial: BYE31M100BO UEFI: American
    Megatrends LLC. v: GZ301VIC.305 date: 04/11/2023
  ID-1: BAT0 charge: 45.4 Wh (81.1%) condition: 56.0/56.0 Wh (100.0%)
  Info: 14-core (6-mt/8-st) model: 13th Gen Intel Core i9-13900H bits: 64
    type: MST AMCP cache: L2: 11.5 MiB
  Speed (MHz): avg: 2525 min/max: 400/5200:5400:4100 cores: 1: 3000 2: 3000
    3: 419 4: 3000 5: 3000 6: 3000 7: 671 8: 3000 9: 636 10: 3000 11: 3000
    12: 3000 13: 3000 14: 3000 15: 3000 16: 3000 17: 787 18: 3000 19: 3000
    20: 3000
  Device-1: Intel Raptor Lake-P [Iris Xe Graphics] driver: i915 v: kernel
  Device-2: NVIDIA AD106M [GeForce RTX 4070 Max-Q / Mobile] driver: nvidia
    v: 530.41.03
  Device-3: Shinetech USB2.0 5M UVC WebCam type: USB driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.8 with: Xwayland v: 23.1.1 driver: X:
    loaded: modesetting,nvidia dri: iris gpu: i915 resolution: 2560x1600~165Hz
  API: OpenGL v: 4.6 Mesa 23.0.3 renderer: Mesa Intel Graphics (RPL-P)
  Device-1: Intel driver: N/A
  Device-2: Intel driver: snd_hda_intel
  Device-3: NVIDIA driver: snd_hda_intel
  Device-4: No brand CalDigit TS4 Audio - Rear type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  API: ALSA v: k6.3.1-arch1-1 status: kernel-api
  Device-1: Intel driver: iwlwifi
  IF: wlan0 state: up mac: f0:57:a6:91:d1:7e
  Device-2: Intel Ethernet I225-LMvP driver: igc
  IF: enp48s0 state: up speed: 2500 Mbps duplex: full mac: 64:4b:f0:38:62:90
  Device-1: Intel type: USB driver: btusb
  Report: rfkill ID: hci0 state: up address: see --recommends
  Hardware-1: Intel Volume Management Device NVMe RAID Controller Intel
    driver: vmd
  Local Storage: total: 953.87 GiB used: 333.53 GiB (35.0%)
  ID-1: /dev/nvme0n1 vendor: Micron model: 2400 MTFDKBK1T0QFM
    size: 953.87 GiB
  ID-1: / size: 777.57 GiB used: 333.47 GiB (42.9%) fs: btrfs
    dev: /dev/nvme0n1p7
  ID-2: /boot/efi size: 256 MiB used: 65.1 MiB (25.4%) fs: vfat
    dev: /dev/nvme0n1p1
  ID-3: /home size: 777.57 GiB used: 333.47 GiB (42.9%) fs: btrfs
    dev: /dev/nvme0n1p7
  ID-4: /var/log size: 777.57 GiB used: 333.47 GiB (42.9%) fs: btrfs
    dev: /dev/nvme0n1p7
  ID-1: swap-1 type: partition size: 32 GiB used: 0 KiB (0.0%)
    dev: /dev/nvme0n1p8
  System Temperatures: cpu: 44.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 447 Uptime: 0m Memory: 30.98 GiB used: 3.61 GiB (11.7%)
  Shell: Zsh inxi: 3.3.26

Memory and storage wise everything seems to be fine.

I suppose you can update the following packages from your list, because it is unlikely that they are causing your issue:

sudo pacman -Sy adwaita-cursors adwaita-icon-theme ca-certificates-mozilla eos-bash-shared eos-translations gsl lib32-nss libgirepository libimobiledevice libplist libusbmuxd perl step welcome zenity

after that reboot and see if boot time and Dolphin start are working normally.

If so, it narrows it down to
dkms - dynamic kernel module system
solid - hardware integration and detection
gjs, gobject-introspection, gobject-introspection-runtime, webkit2gtk - these packages are imho linked to the Gnome project rather than KDE
nss - network security service
usbmuxd - USB multiplex daemon for iPhones and other apple devices
kio-extras - some extra stuff for KDE’s resource and network abstraction

Those packages would have some potential to cause issues I guess. Why do you have this Gnome packages on your system? Did you switch DE’s at some point or do you need them for specific applications.

If Dolphin is the only application that is affected my bets would be on usbmuxd or kio-extras for causing the trouble.
In general you can update one after another and reboot in between to see which of these updates is causing your issues.

libgirepository libimobiledevice libplist are all requirements by upower and were somehow causing my issues. Updating these ended me unable to load up sddm proper. In a tty I removed and reinstalled them and upower (which I found had starting issues see post before). Then I did a proper update of the system still in tty and rebooted. Whatever was broken in my upower was fixed and now everything is up to date and running again. Thanks everyone to help me pin point the issue


If you were able to adequately investigate and interpret the logs, I am sure that you wouldn’t have asked for help here. :wink:
Post full logs and other terminal output as requested, so someone else may see some helpful message.

Boot to a clean session and post this here:

systemd-analyze critical-chain

Post this to a web paste bin service:

journalctl -b

woops, should have read your previous post more carefully.

Good that it’s solved now.

That’s what you could (nay, should) have done in the first place. :v:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.