Update failure on 82 updates

Hello Devs

Hope this post is in the correct place…?

Had screen notification for 82 updates so did the usual; instigate update from the welcome window.

It started okay but quickly locked up – froze – no mouse or keyboard. As you can see from camera photo the clock froze at 11:06:55 – I left it for about 20 mins before powering off.

After two reboots it is still reading “error: failed to synchronize all databases (unable to lock databases)”


Will try again later

not really a BUG on EndeavourOS this can happen in some circumstances where you may stop an update or something crashed e.t.c.

first try to remove the lock file:
sudo rm /var/lib/pacman/db.lck
What in 99% should solve such issue adter this first update db only:
sudo pacman -Sy
if it fails again give the exact output and please no screenshots for text… use:


</> from the menu on post editor after copy paste the text from terminal into the editor and mark it.


Thank you Doktor, and thanks for being polite re using screenshot. I have yet to use that symbol on text or anything - what do you do - swipe it then click the symbol…?
Will try your terminal commands - then reboot and try to update again.
Where should I have posted this update issue?
Thanks again for rapid resonce :slightly_smiling_face:

Hey @joekamprad I think you have solved the issue as all seems to be okay now.
I ran those two terminal commands you gave me and…

[anglo@anglo-latitudee6420 ~]$ sudo rm /var/lib/pacman/db.lck
[sudo] password for anglo: 
[anglo@anglo-latitudee6420 ~]$ sudo pacman -Sy
:: Synchronising package databases...
 core is up to date
 extra                          1585.1 KiB   145 KiB/s 00:11 [--------------------------------] 100%
 community                         5.9 MiB   238 KiB/s 00:25 [--------------------------------] 100%
 multilib                        148.5 KiB  47.7 KiB/s 00:03 [--------------------------------] 100%
 endeavouros is up to date
[anglo@anglo-latitudee6420 ~]$

Now the old age pensioner can also use </> :man_white_haired: :man_technologist: :wink: Thanks to the Doktor :ok_hand:

1 Like

I moved it to “General System”

After running that command you should always update to make sure your system is up-to-date. Especially since something failed during your previous update.


Thanks @dalto - I was just about to do that - out of curiosity?
Will reboot and try “Update System” from the welcome window again.


You should update before rebooting in most cases.


Phew that was close! I just noticed notification top right as I was closing tabs.
Will take your advice - old habits die hard :face_with_monocle:


yea i forget that :wink:


much more easy to copy paste from that in case i need to do some research. :heavy_check_mark:

All 82 updates installed. After advised reboot all seems to be okay.

There were a few warnings which I have pasted just in case someone is
interested in the firmware side.
==> Image generation successful

==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'fallback'

-> -k /boot/vmlinuz-linux -c /etc/mkinitcpio.conf -g /boot/initramfs-linux-fallback.img -S autodetect

==> Starting build: 5.15.7-arch1-1

-> Running build hook: [base]

-> Running build hook: [udev]

-> Running build hook: [modconf]

-> Running build hook: [block]

==> WARNING: Possibly missing firmware for module: aic94xx

==> WARNING: Possibly missing firmware for module: wd719x

==> WARNING: Possibly missing firmware for module: xhci_pci

-> Running build hook: [keyboard]

-> Running build hook: [keymap]

-> Running build hook: [consolefont]

==> WARNING: consolefont: no font found in configuration

-> Running build hook: [encrypt]

==> WARNING: Possibly missing firmware for module: qat_4xxx

-> Running build hook: [openswap]

-> Running build hook: [resume]

-> Running build hook: [filesystems]

-> Running build hook: [fsck]

==> Generating module dependencies

==> Creating zstd-compressed initcpio image: /boot/initramfs-linux-fallback.img

==> Image generation successful

( 8/15) Reloading system bus configuration...

( 9/15) Warn about old perl modules

(10/15) Check if user should be informed about rebooting after certain system package upgrades.

==> INFO: Reboot is recommended due to the upgrade of core system package(s).

(11/15) Compiling GSettings XML schema files...

(12/15) Updating icon theme caches...

(13/15) Checking which packages need to be rebuilt

(14/15) Updating the info directory file...

(15/15) Updating the desktop file MIME type cache…

Seem to have developed a ’ before and after all text when pasted from LibreOffice Writer even though I had removed formatting – Oh Dear…?

Can I say a big thank you to all for your help not only with this issue but for the education also – cheers :+1:

1 Like
1 Like

Those are all normal. Glad to hear everything is OK.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.