Update failed retrieving 'endeavouros.db'

Hey beautiful people!

Ok, feel like a noob. But I get the following error when I update my system:

$ sudo pacman -Syu
:: Synchronizing package databases...
 endeavouros is up to date
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
error: failed retrieving file 'endeavouros.db' from ca.gate.endeavouros.com : Failed to connect to ca.gate.endeavouros.com port 443 after 2872 ms: No route to host
:: Starting full system upgrade...
 there is nothing to do

I updated all my mirrors, and update doesnt seem to be problematic. Does someone know, has this to do with the EOS repo? How to fix, should I change the EOS mirror?



Solution in 1 min, good job! Thanks so much, didnt know about this… :rofl: :rofl: :innocent: so basically eos mirrors have to be ranked independently from arch mirrors if I understand correctly.

Yes, that’s it.

And you could create an alias in your ~/.bashrc that ranks both mirrors, e.g.:

alias rank-mirrors='sudo bash -c "eos-rankmirrors ; reflector -cus -phttps --latest 15 --sort rate --save /etc/pacman.d/mirrorlist"'
1 Like

Do you think either of these two are good ideas?

  1. Add rank eos mirrors button in welcome
  2. Add rank eos mirrors feature to reflector-simple
1 Like

The first depends on how many users actually use welcome. But that is something I could consider adding.

The second sounds to me like mixing too much stuff in one app, and it is easy to create an alias or whatever to add both apps in a single command.


Probably an excellent idea, especially for noobs who are likely to use the welcome app. I use it just to rank mirrors because it’s quick and handy!

A button for ranking EndeavourOS mirrors has been added to Welcome, and should be available on mirrors soon.
Note that it runs in a terminal window.


I am so glad that my ignorance led to a positive outcome! :grin:

1 Like


1 Like

Btw, where are the buttons near the lower edge?
Lost in translation? :wink:

this is just a selected region, because I got tiling enabled on gnome… I have the buttons on the bottom. :grin:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.