Update error with endeavouros.db, and keyring not found

Hey everyone, I tried updating my computer for the first time in a few days and this error suddenly started happening.

It happened for the first time while trying to install krita (screenshot above), but it happens with any package. I tried reranking mirrors and reinstalling both archlinux-keyring and endeavouros-keyring packages, and that’s when this other error happened:

The endeavouros-keyring package can’t be found, and I don’t know how to fix this at all. Can anyone help?

1 Like


Could you post the output of:

file /var/lib/pacman/sync/*


pacman-conf -r endeavouros


:no_entry: Please don’t post screenshots of the terminal output!

Copy the output as text, paste it into the reply box, highlight it and press Ctrl-E to format.

1 Like

Sorry, this is my first post in a forum of any kind so I wasn’t familiar with the fact I can’t post screenshots of term output.

file /var/lib/pacman/sync/* has this output:

/var/lib/pacman/sync/core.db:            gzip compressed data, from Unix, original size modulo 2^32 593920
/var/lib/pacman/sync/endeavouros.db:     HTML document, ASCII text, with very long lines (4070)
/var/lib/pacman/sync/endeavouros.db.sig: HTML document, ASCII text, with very long lines (4070)
/var/lib/pacman/sync/extra.db:           gzip compressed data, from Unix, original size modulo 2^32 32931840
/var/lib/pacman/sync/multilib.db:        gzip compressed data, from Unix, original size modulo 2^32 655360

and the output of pacman-conf -r endeavouros is the following:

Usage = All
SigLevel = PackageNever
SigLevel = DatabaseNever
Server = https://mirror.nimatarlani.com/endeavouros/repo/endeavouros/x86_64
Server = https://mirrors.gigenet.com/endeavouros/repo/endeavouros/x86_64
Server = https://mirror.moson.org/endeavouros/repo/endeavouros/x86_64
Server = https://mirror.accum.se/mirror/endeavouros/repo/endeavouros/x86_64
Server = https://endeavouros.ip-connect.info/repo/endeavouros/x86_64
Server = https://mirrors.nxtgen.com/endeavouros-mirror/repo/endeavouros/x86_64
Server = https://md.mirrors.hacktegic.com/endeavouros/repo/endeavouros/x86_64
Server = https://mirror.alpix.eu/endeavouros/repo/endeavouros/x86_64
Server = https://mirrors.tuna.tsinghua.edu.cn/endeavouros/repo/endeavouros/x86_64
Server = https://fosszone.csd.auth.gr/endeavouros/repo/endeavouros/x86_64
Server = https://mirror.funami.tech/endeavouros/repo/endeavouros/x86_64
Server = https://ftp.belnet.be/mirror/endeavouros/repo/endeavouros/x86_64
Server = https://mirrors.urbanwave.co.za/endeavouros/repo/endeavouros/x86_64
Server = https://mirror.archlinux.tw/EndeavourOS/repo/endeavouros/x86_64
Server = https://de.freedif.org/EndeavourOS/repo/endeavouros/x86_64
Server = https://mirrors.jlu.edu.cn/endeavouros/repo/endeavouros/x86_64
Server = https://mirror.freedif.org/EndeavourOS/repo/endeavouros/x86_64
Server = https://mirror.jingk.ai/endeavouros/repo/endeavouros/x86_64
Server = https://mirror.albony.xyz/endeavouros/repo/endeavouros/x86_64
Server = https://mirror.sjtu.edu.cn/endeavouros/repo/endeavouros/x86_64
1 Like

No problem! The formatted text is much more readable. It makes it possible also to quote and comment on a piece of output etc.

Anyways, please have a look at:

Thank you! Sorry for the delay with responding but I just tested it out and this solution worked. Your help is very much appreciated!

1 Like

You are welcome! Glad you could resolve the issue!

And welcome to EnOS’ community @Cheesy !

:enos: :handshake:t5:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.