Update caused ext4-fs error

I ran a system update and was recommended to reboot after. However the machine does not boot anymore and instead displays the following error messages:

The errors are all cut off in the picture but since there is an attempt to remount the filesystem readonly, they probably indicate issues with your filesystem. Did you reboot when you got the notification or did you wait for the update to finish?

Either way, I would boot off an ISO and try running fsck on that partition.

I rebooted when I got the notification. Gonna try to rescue it from a Live USB thanks

In the future, you should make sure the update is finished before rebooting.

Please let us know how that goes.

I have tried repairing the filesystem with fsck and even e2fsck. Unfortunately the error persists. I can mount the filesystem and chroot into it. Is there anything else I could be doing or do I have to reinstall? Here is the full error:

Update: fsck worked now, but its giving different errors (at least)

Have you checked the smart status on that disk? Is it possible it is failing?

I have, and no errors here

It is clearly failing to read the filesystem.

When you ran fsck, did you ask it correct the errors?

I did and it didn’t report any errors during running.

Even after a fresh install the system is unable to boot as the nvme is inaccessible. Looks like its a hardware error, thanks for the help anyway

1 Like