Update Breaks Login Screen And Everything Else, Wayland

I have just uploaded what happens to YouTube:
EndeavourOS Breaks After Update - YouTube (I know camera is VERY bad. Tried to mod the phone, didn’t go well.)

First I open ‘shutdown panel’ to show it opens. Then I update the system (because I restored from snapshot, there is a pacman lock. Removed it.) Then I try to open the ‘shutdown panel’ again and it is just dark screen. Then I switch to TTY3 and reboot. Now theme is broken. Logging in with Wayland, it doesn’t do anything. Logging in with X11, it starts autostart apps but can’t move the application or do Alt+F3. Then I try Ctrl+Alt+Del (opens ‘shutdown panel’) and it’s just black screen. That’s all of the symptoms I could find.


file:///usr/share/sddm/themes/breath2/main.qml12:1 plugin cannot be loaded for module “org.kde.plasma.core”: Cannot load library /usr/lib/qt/qml/org/kde/plasma/core/libcorebingingsplugin.so: (/usr/lib//ibKF5KIOcore.so.5 undefined symbol: _Z...)

Did you customize your login screen from the Plasma default?

Login screen (sddm) breaking is either the greeter code or your graphic drivers not matching the kernel.

I just didn’t do anything except this to fix Wayland KFontViewer issue: cp /usr/share/applications/org.kde.kfontview.desktop ~/.local/share/applications/

Well - something is not right in your file system - from experience l’'d say it looks like a partial sync/update.

Then I suggest you logout - switch to a TTY - login and run a full system update.

sudo pacman -Syu

In case I confuse you with the TTY term - after logout press CtrlAltF4 - this will bring you to a black screen with a login prompt - that is TTY.

When the update has completed enter reboot and press Enter


I couldn’t understand how this would be the fix since it is what makes the problem occur (even after restoring and updating again) but still tried. It says there is nothing to do as expected.

Edit: Should I restore to working condition or should it stay like this? (For further troubleshooting)

that way, you basically locked your system on the old version as stuff inside your home always has a higher priority then stuff in /usr, but the stuff inside your home does not get updated. That would equal a partial update.
Undo that and check if the issue still happens.

1 Like

Nope, same result after update.

(Restored, removed that file I copied and updated the system.)

Anyone, any idea?

:frowning: This has also been happening to me for a few months! For a while downgrading the plasma-framework package would fix it, but after plasma 6 was released that stopped fixing it. I’ve switched over to gnome since then, but now I’m thinking it’s time for another fresh install of endeavour

I found the solution a few days ago. It was because the karchive-git package. Switched it and everything related to it to normal releases and that was the solution. Maintainer for that package made some changes about Qt versions so that was the reason. Not sure if it would be the solution for you.

1 Like

Thanks for posting the solution! Bummer, into the ignorePkg it goes for now

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.