Update Aorus BIOS on Linux

hello all,
a few weeks ago, I installed Endeavour OS on my laptop Aorus 15 XE5, everything went peachy, everything worked, I used the online installer, installed all available DEs and all available kernel channels (LTS- Zen and normal)
then I began to customize the system a little bit, installed Steam and other packages, then I installed Wayland (because, you know, X11 is dying and all DEs are moving toward Wayland)
after an update and a reboot, I found out that the keyboard is not working (the built-in keyboard mind you because the USB one works but there’s a problem of actual space to keep the external keyboard, my room is tiny and the table only supports the laptop besides some drawers and stuff) so what I found is the fact on logging in then logging out (doesn’t matter, closing the session or just switching user) and then logging in again works to restore my keyboard functionality
PS: I am only using KDE
someone pointed to me that having all DEs puts me in an unsupported situation so is there a proper way to delete all DEs and keep only KDE please?
and they also pointed out that my BIOS may be the cause so I should update it (the inxi -b command returned that my BIOS has 2022 build) so is there a proper way to update the BIOS on Endeavour OS please?
PS: my laptop doesn’t support dual booting, weird right? but I really tried several times to install windows on a newly-created 100Gb empty space but it always throws an error, I also tried running the utility using Wine and Proton, it crashes always, I also tried to run the utility on a windows PE environment, it either crashes the system or I need to connect a network and the utility doesn’t show available Wifis and I can’t connect the laptop via ethernet, unless I share my Wifi network from another network connected via ethernet, but I did not find any guide for that, fwmngr doesn’t support my laptop
can you assist me please?

While some DE’s are looking to drop support for X11 its not going anywhere anytime soon.

Best to run a VM if you need multi-desktops this makes it easy to switch between them without causing problems for other desktops.

That depends on the OEM of your Laptop. For me on my Lenovo I have to use Hirens Boot CD since Lenovo only makes updates under windows systems for my Laptop. However there are some who have a live type environment that you can install from. I would recommend just downloading the bios update file and copy to a USB device boot the Hirens and then run the exe from the external USB thumb drive.

never heard of this before not that it would surprise me that they would do this kind of thing. However if you can boot from another device besides the HARD DISK then you should have multi boot support. You will need to use a boot loader like Grub or Systemd-boot in order to change between systems.

1 Like

With great difficulty, I would do a reinstall and as @thefrog mentioned if you want to try out others do it in a VM

1 Like

hello and thanks for answering

I tried that, I have MediCat that has all PC maintenance utilities including several copies of GRUB live CDs but no one can relaunch the installation of windows,

so it always throws an error, tried 11 and 10, no dice, same problem

if it were that easy I would do it without posting, but

the system either crashes or I cannot connect to the internet, if you see the Aorus 15 XE5 BIOS updater, it is a tiny web only package, I tried extracting the installer, just found some files, a flashing software and 2 folders called Gen1 and Gen2, I didn’t bother to open them because how on earth would I know if my laptop is gen1 or 2?

thanks for answering

Endeavour OS was not my first OS on the laptop, I already tried to migrate all my data, suffice it to say that it did not go well, I just cp -r from my old OS to a previously empty external HDD and I just kept it with my data because I know I might need it again, I could not pinpoint exactly the data I needed but one thing is sure, they were not just in /home, they were all over the place, so preferably I won’t format again

What was that error?

Also what do you mean by empty space, a formatted partition or just unallocated?

I have successfully installed Windows after a Linux system on an unallocated apace without Windows’ installer complaining. I did however removed the esp,boot flag from Linux’ ESP in order to prevent Window’s writing to that partition and creating its own ESP.

Not sure what your trying to do but Grub or Systemd-boot should be installed during installation. Running them from another drive is not installing them onto the system.

No nothing about Windblowz anymore havent used in 15 plus years

Sounds like to me you need to do some reading up on the System you own. Learn how to do things for it. If you have a flashing software I would assume it would be able to tell the difference however since i have no familiarity with your specific device i cannot say for sure.

Best advice I can give is to slow down read an learn about your Laptop. I would also suggest reading the arch wiki more and getting yourself familiar with it if you plan on staying with and arch based system.

unallocated, so that windows can set up its own environment without any potential problem

ok, if I remember this correctly, it was “error at the installation: could not set up the boot settings to continue installation” or something like that, I am 4KM away from my laptop at least at the moment, I will make a photo when I return home, the point is, I can’t install, tried several methods, including trying different versions of the OSes (10 and 11)

I know, it was the first time I saw the error and I installed a LOT of times windows, from 94 to 11

my constraint is that I don’t want to modify Linux in any way just to install windows, I only need it to update the BIOS anyway

GRUB is present by default on EOS so… I don’t need installing it

what I know is that the laptop doesn’t support nor has a guide for Linux, so after spending several hours in searching, I concluded that there is no guide, so I just tried to DIY

I am calm, the “several hours of research” was on a long time, what keeps me stressed is that I have to login & log out & log in every time I reboot my system, and like I said, there’s no guide for Linux, however, there’s a guide for older models and Aorus desktops

The boot,esp flags are only needed at the hour of the installation of the system.

Their being there or not afterwards will have no effect on the functioning of the OS.

Also, if you don’t remove them, Windows’ installer will use your Linux’ ESP as the location for writing its bootmgr to. So that would be an unwanted modification to your Linux system if you feel being constraint by not wanting to modify it.

A guide is not what i was talking about or referring to. I mean support for the system. Does Linux support all the hardware of the Laptop? Does Arch support all hardware of the Laptop.

I’m not talking about being calm just saying slow down and read and research about the product your purchased. While its always best practice to do this prior to a purchase the fact is many don’t so I suggest you find out from others who own the laptop their experiences Does your laptop have a support forum? Have you asked others in that forum about their experiences?

if you are referring to “support” as having drivers and all the hardware work as intended then yes, it is supported, for example, the laptop has an IR camera for windows hello, howdy uses the camera and works as intended, however I disabled it due to me using the laptop only at night where the webcam doesn’t perfectly work, but at the day, it works no problem

if there is a forum, then I didn’t find it, besides, Linux is like a slur for the gaming laptops (with Nvidia cards and intel CPUs and fully licencing the latest winlol)

I wouldn’t know i don’t game.

I have an aorus elite motherboard in a desktop that i built that has never had windows installed on it.To get into the bios at startup you press the del key.Once in the bios you can see what ver motherboard you have.There’s and option to update the bios which is very easy.As has already been posted you download the correct file from gigabyte’s site unzip it and put the file on a usb drive.Also other DE’s on the same system will cause issue’s as will trying to use a boot loader thats’s not designed to work with linux.

this is why I insist on the word “laptop”, the desktop and the laptop are totally different things, on the desktop you have a GUI with a mouse support, and something called “Q-flash” to update the BIOS easily if you have a file, and to access it, you need to press Del, however on laptops, the button is F2, the UEFI interface is semi-text, you know, like a CMD but with some colors, there’s no option called “Q-flash” nor something like that and the mouse is not supported, on DELL however, the UEFI has a GUI everywhere and a mouse support
besides, on the laptop, the BIOS update utility is a web installer, and there is no other file available, so no other choice can be done other than using winlol

No guarantee that this will work, but I, personally, would:

  1. remove boot,esp from Linux’ ESP
  2. Reset the UEFI settings to its default (load optimized default or some such)
  3. make sure that both Secure Boot and TPM 2.0 is enabled in UEFI settings
  4. start Window’s installer, point it the unallocated space and hope for the best :wink:

hi again
well I tried what you suggested, still the same thing

If no other forum member will chime in with a working solution, you might perhaps want to try your luck on a Microsoft/Windows dedicated forum. Good luck :v:t5:

Thanks for having patience & assisting me

I wanted to avoid that but I suppose I have no other choice, apart from waiting more time