**UPDATE 2.0** reFIND being weird with custom theme

Update - Refit does same thing, if using custom theme???
This thread was originally for my black screen issues, which fixed with reFIND, however, now to get into endeavourOS i have to go through systemD-Boot, which is fine and all but feels a bit odd. Are there any config files I can go through to go straight to endeauvourOS

archived -
Hello! So, I’m confused out of my mind, about this weird problem, it is essentially, if I hard power reset I have to more on that below, I will boot into endeavoros, it’ll just be black, along with my bios screen etc. being black Gigabyte mb. I have found turning on CSM fixes it sometimes, however, that breaks sleep mode, which then won’t turn display back on if I ever go into sleep mode… Now how do I currently fix it? Well, I blindly guess which one is Windows, go into windows, click restart, and then it all works normally. My startup logs look normal every time, and, same results if i click restart in enderavorOS, they’re installed in different ssd/hdd.

You would probably have to convert your system a bit if you want to avoid systemd-boot. It may be easier just let refind load systemd-boot.

What filesystem are you using?

Uh, not sure what answer you’re looking for here’s output of lssblk:

Filesystem     Type     1K-blocks     Used Available Use% Mounted on
devtmpfs       devtmpfs      4096        0      4096   0% /dev
tmpfs          tmpfs      8105688        0   8105688   0% /dev/shm
tmpfs          tmpfs      3242276     2216   3240060   1% /run
/dev/sda2      ext4     959291696 26015424 884473192   3% /
tmpfs          tmpfs      8105688       20   8105668   1% /tmp
/dev/sda1      vfat       1021952   291564    730388  29% /efi
tmpfs          tmpfs      1621136       80   1621056   1% /run/user/1000

sda is my Linux hdd
sda1 is mounted as /efi
sda2 is the main mounted as /

Oh also, I tried installing theme and reFIND failed to show the theme, *adding the include themes/rEFInd-minimal/theme.conf into refind.conf, and making themes folder and putting the theme in there. Not sure if related or not.

Try adding linux to the list of extra_kernel_version_strings in refind.conf

Already tried that :frowning: didn’t work

It is possible that refind isn’t compatible with the kernel naming standard used by kernel-install.

You can convert your system to not use that anymore if you want to. Keep in mind, that would require you to configure several things on your own.

are there more details on doing the transfer?, as long as I still have windows as a backup, idgf about my Linux installation Mostly using it to get more familiar with Linux I found some older posts, but they’re very unorganized. Also i think I fixed the themes by renaming the folder

I don’t think anyone has written or tested any instructions.

Interesting, what do you suggest to do? I looked thru conf, and found this think this would help?

# When scanning volumes for EFI boot loaders, rEFInd always looks for
# macOS's and Microsoft Windows' boot loaders in their normal locations,
# and scans the root directory and every subdirectory of the /EFI directory
# for additional boot loaders, but it doesn't recurse into these directories.
# The also_scan_dirs token adds more directories to the scan list.
# Directories are specified relative to the volume's root directory. This
# option applies to ALL the volumes that rEFInd scans UNLESS you include
# a volume name and colon before the directory name, as in "myvol:/somedir"
# to scan the somedir directory only on the filesystem named myvol. If a
# specified directory doesn't exist, it's ignored (no error condition
# results). The default is to scan the "boot" directory in addition to
# various hard-coded directories.
#also_scan_dirs boot,ESP2:EFI/linux/kernels

Do you think, my efi/EFI is there, and not in /boot/efi/EFI ? My friend has the same setup as mine, and it works flawlessly for him with systemd-boot The only difference being that.

Something sounds strange about this - does rEFInd not come up on boot? It should present AT LEAST enough choices to get anything started you wish. Usually it gives you some choices you DON’T want, which you then hide. It will automatically detect and present a Windows choice if that is present.

If rEFInd is not in charge on bootup, not sure WHAT is happening! Easy way to re-activate it is to run refind-install (it won’t overwrite modified files in your setup) or you can create your own entry in NVRAM if you choose to…

Have you tried running refind on one of our systemd-boot setups which uses different naming and location for the kernels and initrds?

It probably needs some configuration to find those properly.

Certainly possible - I’ll have to look at it. I didn’t ‘worry’ because systemd-boot isn’t needed either if rEFInd is in use… Back later!

I tried it and it only has a systemd boot entry and a fallback initramfs entry.

Heyo! Thx for your replies, I’ve since discovered some more interesting things??? Well first off, I have found this weird juggling of key combination pressing, after which I can hard restart my computer yanking the cord, or holding the top button like a sane person, which will then bring me into reFIND menu, which I can then use to goto SystemD-Boot, which will then take me into EndeavourOS, and work flawlessly. However, I’m not very happy bout my 5-10 mins juggling and pure panic of my system going black… I’m considering a fresh install of the whole OS, using this time Grub

If you use grub it’s easy to boot from refind using either the grubx64.efi or the vmlinuz-linux image file. You have to set it up though to boot from which ever one you want to use.