Unwanted changes in "Key to choose the 3rd level" option

Hello dear community,
recently I discovered some annoying behaviour of the above mentioned Additional layout options which can be accessed and changed via gnome-tweaks in the Keyboard & Mouse window. I’m using the Neo2 layout, where Right Alt is used to access the 4th layer which has useful functionality like jumping to the beginning or end of the current line and so on.
I already noticed, when I installed EOS, that the option “Key to choose the 3rd level -> Right Alt” was checked, which prevented the Right Alt key from accessing the 4th layer, so I unchecked it and everything worked fine as intended. Now, after certain upgrades, I find that this setting is again checked, which is not the end of the world, but pretty annoying because I always have to manually uncheck this setting until the next time an upgrade resets it.
Because the Arch Wiki states that only full system upgrades are supported and recommended, I didn’t dare to nail this problem down to a certain package, but I thought maybe someone here has an idea which package upgrade could cause this behaviour?

The last system upgrade that broke the setting:

Packages (20) alsa-lib-1.2.4-2  ca-certificates-mozilla-3.58-1  ethtool-1:5.9-1
              faad2-2.10.0-1  firefox-82.0-1  freetype2-2.10.4-1  git-2.29.0-1
              glib2-2.66.2-1  gsfonts-20200910-1  gspell-1.8.4-1
              iproute2-5.9.0-1  js78-78.4.0-1  libgdata-0.17.13-1
              libimagequant-2.13.0-1  libpwquality-1.4.4-1  libvirt-1:6.5.0-3
              mesa-20.2.1-1  nss-3.58-1  python-cairo-1.20.0-1  tracker-2.3.6-2

Any hints are appreciated :slight_smile:
Greetz, smokee

you may could set this with setxkbmap outside gnome-settings

I’ll try that and see if it works, thank you :slight_smile:

ok, I finally found out what caused the unwanted behavior. After @joekamprad’s solution didn’t work, I noticed that the option was also set every time I changed some settings in the gnome-control-center aka Gnome Settings (for example after I added a custom keyboard shortcut). Then I recognized the Alternate Characters Key setting at the very top of the Keyboard Shortcuts tab in the Settings, which was set to Right Alt (which I guess is the default setting). This caused the explained behavior.
I thought I’d just add this in case anybody happens to run into a similar “problem”
:slight_smile:

4 Likes