Unmount an usb stick in dolphin

I am a bit giddy, being whole day reading and trying until i think i am confused

Let me say this:

Initially i was able to mount and unmount my usb stick from both dolpin and terminal
Both method (dolpin and cli) able to unmount successfully multiple time as i was trying out while reading from internet.


But i only know how to mount it back using dolphin (by simple click the device at “removable device” section and it is auto mounted).
i also verified using $lsblk and saw the mountpoint was displayed on the most right column of the device.


then i unmount it to do fix disk using $fsck. i mounted the usb stick back using dolphin after fsck (by simple click on the device and it automount for me)
the mountpoint on dolphin (right click > property ) is “/run/media/enos-andrew”

THEN SUDDENLY i realized i can’t unmount the device using dolphin any more… WhY ?
I felt like i was suddenly wake up into another world… I could not figure out how did i manage to unmount the usb device in dolphin previously !
Now i only see “safely remove” option when right click on the device.
AND when i clicked “safely remove” the device, the device vanished from dolphin !!

Why initially i can unmount the device and remount it (just click the usb device , it will open up the device content , when i check using lsblk, it is mounted *because i see mount point appears again on the device).
Why initially i can mount and unmount easily in dolphin, the device will always there in dolphin.
When unmounted, there is a small red color cross on the device, but the device still listed in dolphin…
Why now, after repairing the corrupted data on the usb stick.
There is only “safely remove” button ( when right click the device) in dolphin. when i clicked “safely remove” the device, THE device actually vanished!! I have to unplug the usb stick and replug it in so that dolphin will mount it again.

What had just happened ?

Dolphin does not show an “Unmount” option for auto-mounted USB flash drives. It only shows “Safely Eject.”

The “Unmount” option will be shown for an external HDD, not a flash drive.

That’s how Dolphin has worked for many years now. Expected behavior of Dolphin is to “Safely eject” a USB flash drive. To remount it you must unplug it and plug it in again.

Since you mention repairing the flash drive using fsck, perhaps Dolphin did not initially recognize the flash drive as a flash drive, therefore giving you the “Unmount” option. That’s just speculation on my part.

A GUI unmounting option, if you should require it, is to go to System Settings > Hardware > Storage Devices, right-click on the USB flash drive, and select “Unmount Device” - if you do this, Dolphin will still display the unmounted flash drive and will offer the “Mount” option.

  1. I did unmount it on dolphin. I did unmount it many times on dolphin. After unmount the usb stick remain in the list, just with a small red cross on it. It is unlikely i confused with $sudo umount.

question: how does the system tell the difference between external HDD vs flash drive ? Maybe there is some registry bit that can make the system think flash drive is external hdd and vice versa .

  1. my 6TB usb external hdd has got “safely remove” instead of unmount. is there way to make dolphin to display “unmount” option together with “safely remove” ? since kde is capable of manual adjustment…

  2. I recall i have tried one time to manually mount my usb stick in terminal. I didn’t know where to mount removable usb stick hence i typed : sudo mount /dev/sde1 /mnt . that time that usb stick was under /sde
    could it be that’s the reason why dolphin drop “unmount” on the usb stick ?

  3. Weird thing is that even though my usb stick after unplug and replugged, changed to "/sdd1 ", but device sde1 still listed in “storage devices” (under system settings), and it mount point still /mnt , as seem in photo.
    what impact does that cause ? should i just leave it there if it disturb nobdoy ? Weird thing is, in dolphin and $lsblk, there is not /sde1 device, why system setting > storage devices still show sde1, vfat , /mnt as mount point ?

You can cause a USB flash drive to be read as a regular HDD; off the top of my head, I don’t recall what is necessary to do that, but IIRC it’s a simple matter of “flipping a bit” that identifies the drive as a removable flash drive.

However, you will be far better off in the long run if you simply use the expected behavior that Dolphin provides. Using “Safely remove” instead of “Unmount” ensures that all data transfer has completed and there is no data remaining in the write cache before the device is powered down. This is a safeguard against data corruption and possible damage to the file system on the device.

If, for some reason, you simply must unmount a USB flash drive instead of using “Safely remove” then either perform that step from a terminal, or via the GUI option I listed above.

Using the default options will be safer for your data and your devices. You will probably have some issues if you try to circumvent the default behavior.

There are CLI command options that will ensure that your data is synced before the device is unmounted, but I think you will be much better served by using Dolphin’s “Safely remove” option. It works very well, and I have USB flash drives that are approaching 15 years in age that still work perfectly.

As to your question about an entry still showing - I really don’t know what you’ve been doing, so I’m not going to waste any time trying to troubleshoot what you have going on. If the entry still remains after a reboot, try right-clicking and unmounting it.