Unlock KDE Wallet

After doing some checking, online I did find this article: https://wiki.archlinux.org/title/KDE_Wallet

Which in part says the following:

Unlocking KWallet automatically in a window manager

To unlock KWallet protected by the login password, it is necessary to add

exec --no-startup-id /usr/lib/pam_kwallet_init

to the configuration file of the window manager in addition to configuring PAM.

Which file would I add that to for the “configuration file of the window manager” ?

1 Like

In plasma, all you need to do is ensure:

  • kwallet-pam is installed
  • Your kwallet password is the same as your user password

Yes, its already installed. Trying to prevent it from asking me for my password after I log in

You need to change your kwallet password to match your user password. Once they match, it should “just work” in plasma.

yeah, same password, not “just working” :frowning:

  • Are you using sddm?
  • Is your wallet using blowfish encryption?
  • Are you using autologin?
  • Have your modified your pam or sddm configs?

This is the base Plasma install from Endeavouros. So yes using SDDM, wallet is using whatever it uses by default, haven’t modified any pam or sddm configs.

No the Linux doesn’t log in automatically

Are you using X11 or Wayland?

I’m using X11

In system setting is the kde wallet subsystem enabled and all the options for closing unchecked?

Yes.

What are the contents of /etc/pam.d/sddm?

It has:

#%PAM-1.0

auth include system-login
-auth optional pam_gnome_keyring.so
-auth optional pam_kwallet5.so

account include system-login

password include system-login
-password optional pam_gnome_keyring.so use_authtok

session optional pam_keyinit.so force revoke
session include system-login
-session optional pam_gnome_keyring.so auto_start
-session optional pam_kwallet5.so auto_start

What is the output of:

ls -l /usr/lib/security/pam_kwallet5.so 
pacman -Q | grep -i kwallet

It’s the following:

-rwxr-xr-x 1 root root 26408 May 3 07:34 /usr/lib/security/pam_kwallet5.so
kwallet 5.94.0-1
kwallet-pam 5.24.5-1
kwalletmanager 22.04.1-1
signon-kwallet-extension 22.04.1-1

OK, how about the logs.

What does this return?

journalctl -b 0 | grep pam_kwallet

It replies:

May 31 04:37:49 omen-endeavour plasma_session[936]: org.kde.plasma.session: Starting autostart service “/etc/xdg/autostart/pam_kwallet_init.desktop” ("/usr/lib/pam_kwallet_init")

Just in case I wasn’t clear earlier, as I don’t think I mentioned it, hopefully it doesn’t waste any of what we have done, its when Nextcloud launches it asks me to unlock the KDE Wallet. I’m hoping that there is a way for me not to have to unlock my wallet but keep both NextCloud and KDE Wallet

It isn’t unlocking your wallet according to the logs. It doesn’t even seem to be trying to do so. :thinking:

Would it hurt anything to remove the Wallet?

You could delete the wallet and let a new default wallet be created and see if that solves the issue.