Unknown signature

Hi
I’m running my first pacman -Syu after a fresh offline install of EOS, and I got this error:

Total Installed Size:  2927.93 MiB
Net Upgrade Size:        32.91 MiB

:: Proceed with installation? [Y/n] 
(368/368) checking keys in keyring                           [--------------------------------] 100%
(368/368) checking package integrity                         [--------------------------------] 100%
error: hidapi: signature from "Balló György <bgyorgy@archlinux.org>" is unknown trust
:: File /var/cache/pacman/pkg/hidapi-0.13.1-2-x86_64.pkg.tar.zst is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n]

I saw this thread about updating the keyring, but it points to a specific “2021” file. How do I fix this with the latest info?

You can do

pacman -Sy archlinux-keyring

Then do

sudo pacman -Su

Future updates you can return to

sudo pacman -Syu

Before I saw your message I tried pacman -U archlinux-keyring which didn’t work (wrong flag I guess, still learning pacman), then I ran pacman-key --refresh-keys, which took a long time and gave a bunch of warnings about people disappearing off the internet timeouts and unacceptable redirects. It seemed to fix the problem.
I just ran your lines now and got some reassuring no-ops.
Thank you.

1 Like

Glad to hear you got it working.

I presume you ran those with sudo, the first one failed possibly because the local cache was out of date. The second worked as it is the manual way, rather than installing/updating the package.

A good resource if you haven’t seen/found it

Pacman rosetta

This can help with the transition from a different package manager.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.