Unfortunately your computer does not support WebGL graphics acceleration; Google Earth cannot be loaded

I have problem using Google earth… WebGL issue.

Tried this:


Log out and log in… but still having the same issue.

WebGL is a plugin on browser itself right ? hav nothing to the os or DE itself right ?

Also, this cloud API “webgl” … does it brings any vunerability ? I did a quick read, it does…
In order to use google earth… any other way to go instead of enable webgl if it is vunerable …?

i think you should set webgl.disabled to false

On my browser, webgl.force-enabled is false

But I get success message on check at this website
https://get.webgl.org/

Weird…
My original setting for webgl.force-enabled is false.
I changed it to true… log out login … but firefox still can’t access goggle earth.

this is the test that i run when my webgl.force-enabled is true.

could it be other plugin that i have installed that blocked it ? … maybe…
I have ublock origin
and decentraleyes plugin installed…

Keep forced enabled to false and webgl.disabled to false and then try. That is the settings I used.

changed to “false”. opened a new to https://get.webgl.org/, but still same.

Does your system have graphics card? (integrated or discrete)

Also, open about:support on your browser and scroll down to the “Graphics” section where you can see the exact configuration on your browser. The relevant screenshot from my browser is here

You can see that my integrated graphics is being used to render WebGL.

hmm. mine have none!
Does not even have the driver… what on earth is that ? ! lol

solved.

it is this that causing the issue…

Thanks @Flyingcakes for leading me to a good tool: about:support :+1:

about:config
webgl.disabled=false

1 Like