Unable to write to NTFS partition with fstab permissions

I have setup an NTFS partition to be accessed from both EndeavourOS & Windows.
This is what I have in /etc/fstab for the partition:

UUID=728A17B58A1774B7 /media/storage/ ntfs-3g uid=1000,gid=1000,dmask=022,fmask=133, 0 0

Although it’s mounted with rw permissions, it’s still read-only.

What might be the reason?

The most common reason is that you haven’t disabled “Fast Startup” inside Windows. When that is enabled it puts the computer in hybrid sleep mode instead of a full shutdown. This leaves the disks marked as dirty and Linux mounts the device read-only.

Also, welcome to the forum!

3 Likes

Logged in to Windows & saw an update was queued (fast startup was disabled). Letting it complete fixed it. Thanks!
Just Windows things :man_facepalming:

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.