Unable to use "Bridge device" on Virt-Manager


I followed the article and it seemed I installed everything successfully. But when I select “Bridge device” under Network selection it gave me an error. Could someone please help? Thanks a lot!


What do the details say on the error? Can you also paste the error output instead of a screenshot, please?

1 Like

Details are shown below. Thanks for your help.

Unable to complete install: '/usr/lib/qemu/qemu-bridge-helper --use-vnet --br=ubuntu22.04 --fd=32: failed to communicate with bridge helper: stderr=access denied by acl file
: Transport endpoint is not connected'

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 72, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/createvm.py", line 2008, in _do_async_install
    installer.start_install(guest, meter=meter)
  File "/usr/share/virt-manager/virtinst/install/installer.py", line 695, in start_install
    domain = self._create_guest(
  File "/usr/share/virt-manager/virtinst/install/installer.py", line 637, in _create_guest
    domain = self.conn.createXML(initial_xml or final_xml, 0)
  File "/usr/lib/python3.11/site-packages/libvirt.py", line 4523, in createXML
    raise libvirtError('virDomainCreateXML() failed')
libvirt.libvirtError: /usr/lib/qemu/qemu-bridge-helper --use-vnet --br=ubuntu22.04 --fd=32: failed to communicate with bridge helper: stderr=access denied by acl file
: Transport endpoint is not connected

It’s a permission issue, double check and make sure you went through the “Run Virt-Manager as normal user (recommended)” section properly. I would also double check all the other steps as well, just in case.
There is some additional info on a possible fix here.

1 Like

I did, all seem correct. But there’s errors when I ran this command:

[apache@um480xt ~]$ sudo virsh net-autostart default
[sudo] password for apache: 
error: failed to connect to the hypervisor
error: Cannot recv data: Connection reset by peer

libvirtd.service status doesn’t look good:

[apache@um480xt ~]$ systemctl status libvirtd.service
× libvirtd.service - libvirt legacy monolithic daemon
     Loaded: loaded (/usr/lib/systemd/system/libvirtd.service; enabled; preset: disabled)
     Active: failed (Result: start-limit-hit) since Mon 2023-12-18 10:45:22 PST; 10min ago
   Duration: 30ms
TriggeredBy: × libvirtd.socket
             × libvirtd-admin.socket
             × libvirtd-ro.socket
       Docs: man:libvirtd(8)
    Process: 6085 ExecStart=/usr/bin/libvirtd $LIBVIRTD_ARGS (code=exited, status=0/SUCCESS)
   Main PID: 6085 (code=exited, status=0/SUCCESS)
        CPU: 78ms

Dec 18 10:45:22 um480xt systemd[1]: Started libvirt legacy monolithic daemon.
Dec 18 10:45:22 um480xt libvirtd[6085]: libvirt version: 9.10.0
Dec 18 10:45:22 um480xt libvirtd[6085]: hostname: um480xt
Dec 18 10:45:22 um480xt libvirtd[6085]: invalid argument: Failed to parse user 'swtpm'
Dec 18 10:45:22 um480xt libvirtd[6085]: Initialization of QEMU state driver failed: invalid argument: >
Dec 18 10:45:22 um480xt libvirtd[6085]: Driver state initialization failed
Dec 18 10:45:22 um480xt systemd[1]: libvirtd.service: Deactivated successfully.
Dec 18 10:45:22 um480xt systemd[1]: libvirtd.service: Start request repeated too quickly.
Dec 18 10:45:22 um480xt systemd[1]: libvirtd.service: Failed with result 'start-limit-hit'.
Dec 18 10:45:22 um480xt systemd[1]: Failed to start libvirt legacy monolithic daemon.
lines 1-23/23 (END)

Honestly, I’m not quite knowledgeable enough to see what’s going wrong. I personally would uninstall all the packages and start over. You never know, you might have missed something originally. Wish I could help more, sorry :confused:

1 Like

Thanks a lot! I really appreciate it!
Did you follow the same installation guide and get the network bridge mode working?

After an attempt at installing it in a VM I actually ran into the same error you did. I thought about maybe setting it as a default connection initially and changing it later but I can’t find my way through the UI. I’m too used to Virtual Box :stuck_out_tongue:

1 Like

Wrong option was selected. If THIS is hard to follow
watch that:


Are you on a wireless connection? afaik it’s a bit trickier to set up a bridge on wifi https://wiki.archlinux.org/title/Network_bridge#Wireless_interface_on_a_bridge


Edit: just google bridge helper: stderr=access denied by acl file saw some good advices

1 Like

Igen, de tegnap én is belefutottam kezdő virt-manager használóként hasonló ágba.
Bocs, a neved alapján gondoltam nekünk is kijár a saját nyelv használata (nem csak a németeknek).
Bár, lehet, hogy felületes vagyok. Nem is neteztem VM-ből.
@mihalycsaba Yes, to be honest I started using virt-manager 14 hours ago.
I was happy to access net using QEMU/KVM.

My host machine has a wired connection.

I did the QEMU/KVM setup with the bridge device a long time ago, that should work well for me so far.

I would recommend you to follow Arch Wiki to learn how to use nmcli for a bridge device.



It’s not explained in the eOS wiki what swtpm is, something is missing, I just removed everything I added from the wiki to qemu.config. Then I managed to start the daemon and connect to the system session. Right now at least I have the default network. Was your bridge device name correct? Did you manage to fix this?

1 Like

Not yet, I don’t see any network (not even default) showing up under the user session. I think I will use the root session. But still need to set up bridge on the host itself, looking for some solid write-up and youtube videos on this. If someone can update the EnOS wiki, it would be very much appreciated!

If it’s helpful, the steps here (https://archsetup.blogspot.com/2023/11/install-windows-11-on-virt-manager.html) worked for me. You can ignore the Windows installation part, but the first part should get virt-manager set up correctly for you.

1 Like

The default network is only available on the system session afaik. Definitely try the system session, I think it would solve the permission errors with bridge device too. You can check the available networks in virt-manager, at least the default should be there in the system session.

I have described here how I reached the guest without a bridge or macvtap just on the default network.

1 Like

as for libvirtd try sudo journalctl -u libvirtd.service | eos-sendlog

as bridge… once of a time my wifi didnt work, but now it works what exactly it is i dont know. first i thought some devices can’t be bridges… as my qemu install is not minimal to :slight_smile:

1 Like

@apachecai what’s the issue, did you try the system(root) session, can you confirm if you see the default network at least? It should be only available in the system session. In user session I can connect to the internet, I just can’t access the vm from host and I can’t list any networks.

[csaba@csaba-mini ~]$ systemctl start libvirtd
[csaba@csaba-mini ~]$ virsh net-list --all
 Name   State   Autostart   Persistent

[csaba@csaba-mini ~]$ sudo virsh net-list --all
 Name          State    Autostart   Persistent
 default       active   yes         yes
 macvtap-net   active   yes         yes