Unable to Update!

It tells you explicitly what is wrong - it breaks a dependency.

You probably just need to wait a bit. One thing may have updated that now causes the next thing to need. It is probably even flagged out of date on the AUR, or if it’s not you can.

More importantly, you should not be running yay -Syyu. Yay alone is all you need 99% of the time unless you’re updating mirrors.


Remove virtualbox-ext-oracle

Update the system.

Reinstall virtualbox-ext-oracle


The AUR package has now been updated to v7.0.8-1.

As @Stagger_Lee suggests the least painful way to update is removing virtualbox-ext-oracle, updattng, and then reinstalling it.


Done, but the naughty me removed virtualbox-ext-oracle then installed then did the update and it went fine!
I wonder why didn’t it update as usual with yay!?
Do I have something wrong with my system?

1 Like

That is the deal with AUR packages. You need to manage rebuilding them.

Do you even need the extensions?


Between the terminal output you posted earlier, and @r0ckhopper’s reply, you should be able to figure this out.


You have been told this at least 4 times in the past:


Me rebuild AUR packages?! extensions? What extensions!
Sorry, I do not understand.
Do I need to do anything to fix this so it would not happen again?
What extensions you mean?

OK, I will be doing just yay! I tried it and it updates the system. Maybe I got it somewhere when I started with Arch based distros.
From now on it will be just yay.
Thank you.

1 Like

Yes, that is what happens when you use yay. It builds a package.

The package virtualbox-ext-oracle are the non-free extensions to virtualbox. I am asking if you need that package at all.

It will happen again. That is how AUR packages work when they have fixed version dependencies.

1 Like

I just installed it to have the possiblity to use USB in the virtual machine(s)

I understand now! Well, I use yay because it updates packages installed from all repos including AUR.

Oooooops! But… AUR has some packages that I might need (some packages that I actually use and didn’t find in pacman repos!, I think most users use AUR.
There should be a way to avoid it I hope. Any?
I do not mind sticking to main repos.
Here are my “foreign” apps on my system:

[limo@asus ~]$ pacman -Qme
aspell-ar 1.2-1
btrfs-assistant 1.8-1
btrfsmaintenance 0.5-2
cnrdrvcups-lb 5.70-2
czkawka-gui 5.1.0-1
(UNINSTALLED -> debtap 3.5.1-1)
dropbox 170.4.5895-1
googler 4.3.13-1
gstreamer0.10-base-plugins 0.10.36-13
(UNINSTALLED -> k2pdfopt 2.53-1)
kio_recoll 1.34.0-1
kopia-bin 0.12.1-1
kopia-ui-bin 0.12.1-2
ocrmypdf 14.1.0-1
pup 0.4.0-3
python38 3.8.16-3
rslsync 2.7.3-1
(UNINSTALLED -> virtualbox-ext-oracle 7.0.8-1)
[limo@asus ~]$ 

I would for sure welcome any suggestions to downgrade (if available in pacman). or use alternative if possible.
But this might be another topic though I do not mind getting feedback here as it is related anyway to the main topic and title of this thread.

The package " downgrade " is available in the EnOS repos. Not sure what you want to use it for as your issue is solved. For further questions regarding problems you encounter it would be good to open another thread, as usual. :v:

I was just thinking, probably the most recent version of some apps might be in AUr, but perhaps older versions can be installed through pacman from main repos.

That is generically false, imo.
Repos are always the latest packages in Arch. AUR-builds depend on these, as they incorporate them. So AUR-packages have to be behind in time, at least somewhat, if not weeks, or even months in some cases… :v:

1 Like

Thanks for clarification.
I am looking now at my “foreign” apps, trying to find alternatives as much as I can to reduce the possibilities of encountering the same situation again!

Two things:

  • This isn’t really a problem. It is just a normal part of managing your system.
  • This doesn’t impact all AUR packages. Only the ones with specific version dependencies.

Sure, I understand now thanks to all of you. You will notice I am reviewing all AUR packages I have and uninstalling some of them.

Ya, don’t update every 15 minutes. And If you update- and you get this issue. . . just wait and it will get updated. I mean, it’s pretty easy to just wait until the AUR package gets updated . . . LOL.

You’ve been saying that since August. . . I’m a pretty terrible person and even I don’t flat out purposely waste the money of generous mirror maintainers. So, you’ve been told, informed, explained to about it, and yet. . . 8+ months later you’re STILL knowingly and purposely wasting someone else’s money. You can’t say you didn’t know. 99% sure you’ll get caught again in the future wasting everything that goes into maintaining and running a mirror.

Don’t tell us you’ll stop. Just stop. It’s literally easier for you to not waste resources.

1 Like

That isn’t the issue.

The issue is that repo packages get updated before AUR packages. The repo packages fail to update because the AUR package has a hard dependency on a fixed version.

This is only an issue with a small percentage of AUR packages that have dependencies on specific versions of repo packages.

1 Like

I admit it yes… it was like a habit, but well, I finally got a clean:

[limo@asus ~]$ yay
:: Synchronizing package databases...
 endeavouros is up to date
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Searching AUR for updates...
:: Searching databases for updates...
 there is nothing to do
[limo@asus ~]$ 

You notice it is only yay!

This shouldn’t be really necessary. Sometimes, missing ‘dependencies’ in AUR packages will catch up over time.

It is always good to look into Arch Linux AUR packages from the Arch website to determine, if one or another package is no longer actively being maintained.

So, if a package gets flagged as out-of-date, the used AUR helper (yay or paru) will mention it any way when updating your system.

1 Like