Unable to update system... Signature is invalid

So I’m pretty much unable to update my system. I tried updating mirrors and i tried everything in this post:

" And if this still doesn’t work, and you trust that the packages are actually correct and not corrupt and haven’t been interfered with, then you can force (re)installation of the keyring packages:

sudo pacman -U /var/cache/pacman/pkg/{archlinux,endeavouros}-keyring*.pkg.tar.zst

then try again."
I still keep getting “signature from “David Runge dvzrv@archlinux.org” is invalid”
“Do you want to delete it? [Y/n]”
i chose N and it keeps giving me other similar messages about signature.

You could try resetting your keys:

@Esgath ,

sudo pacman-key --refresh-keys

Search here offers this.

1 Like

I already did this in the linked post using those steps:
sudo mv /etc/pacman.d/gnupg /root/pacman-key.bak
sudo pacman-key --init
sudo pacman-key --populate archlinux endeavouros
sudo pacman -Syy archlinux-keyring endeavouros-keyring
sudo pacman -Syyu

Okay, so i did the following:

  1. Removed downloads of packages that show as invalid signature:
sudo rm /var/cache/pacman/pkg/jbigkit-2.1-7-x86_64.pkg.tar.zst
sudo rm /var/cache/pacman/pkg/foomatic-db-nonfree-ppds-3:20230903-1-any.pkg.tar.zst
sudo rm /var/cache/pacman/pkg/unrar-1:6.2.11-1-x86_64.pkg.tar.zst

It showed me that i have problems with “archlinux.thaller.ws”, i kept updating my mirrors earlier but it kept adding it, so i picked mirrors from different region.
2. run
sudo pacman -Syu

Problem solved, it seems the mirror stuff was the issue.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.