Unable to update due to dependancy breakage

Looking for some help with updates and dependency issues. When I tried to update it wants to replace a package and when I say y it then says it can’t do the update due to dependency issues. I tried updating my mirrors with no change.

 sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
:: Starting full system upgrade...
:: Replace libcanberra-pulse with extra/libcanberra? [Y/n] y
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing alsa-lib (1.2.5-2) breaks dependency 'alsa-lib=1.2.4' required by lib32-alsa-lib
:: installing libelf (0.185-1) breaks dependency 'libelf=0.184' required by lib32-libelf

Do you have anything in your Ignorepkg line in /etc/pacman.conf? If so, what?

Also, make sure that the multilib repo is enabled in your /etc/pacman.conf. If you blindly overwrote it with the recent pacnew you will have to fix some things.

If neither of those is the problem, there is likely something wrong with your mirror. Try resorting your mirrors from the welcome app.

The issue here is that your upgrade isn’t including those two lib32 packages so the old versions of those is holding the newer packages back.


Looks like Multilib is indeed commented out, can I just enable it and do updates or will i need to fix other things?

1 Like

You can enable it and update.

You need to make sure that the endeavouros repo isn’t also missing.

If it is, add it back.

SigLevel = PackageRequired
Include = /etc/pacman.d/endeavouros-mirrorlist
1 Like

Thank you, that was it. I must not have paid attention when doing pacdiff.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.