Unable to start Plasma session after system upgrade

Hello! I’ve been using EndeavourOS for about a month now. I upgraded again today and can’t start a Plasma 5 wayland or x11 session. Wayland just crashes and goes back to login screen, and x11 just shows a blank screen after loading for a while. I am fully able to login to a tty session.

Looking at wayland-session.log it reads:

Error: could not determine $DISPLAY.
Error: Can not contact kdeinit5!
org.kde.startup: "kdeinit5_shutdown" () exited with code 255

In journalctl the main error (grepping wayland) I see is

Error while loading shared libraries: libqaccessibilityclient-qt5.so.0: cannot open shared object file: No such file or directory

Any idea how to fix this? Thanks!

sudo pacman -S libqaccessibilityclient-qt5 

would be my first try.

I installed libqaccessibilityclient-qt5 and now the wayland session doesn’t completely crash, but now I’m getting that plasma failed to start after it can’t find libKUserFeedbackCore.so.

sudo pacman -S plasma-desktop

That’s what I would try, but don’t blame me if it doesn’t work.

Same error sadly. I can’t find what package that library is in.

Package “kuserfeedback5”

It worked after installing that. Looks like it was just a matter of finding all the dependencies that weren’t installed (libqaccessibilityclient-qt5 and kuserfeedback5). Thanks!

1 Like

looks like you said no to the questions where you should have said yes (replace plasma packages with plasma5 packages).
Or you rebooted while the update was still running.

I recall seeing the prompt, and I at least meant to hit yes, but I may have hit no by accident.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.