Unable to start live environment


I’m trying to get EndeavourOS installed on an old Macbook Pro. For full context in case it matters, it’s run EndeavourOS immaculately in the past, and is currently running MicroOS. This time around, though, I can’t seem to get the live USB to work properly. I make it as far as the initial boot menu, and then all the options seem to lead to the same issue:

Initramfs unpacking failed: ZTSD-compressed data is corrupt

The live environment doesn’t load. I’ve downloaded the ISO from multiple mirrors, verified the files with sha512sum, and tried two different USB drives, to no avail. One of the drives contained an older EndeavourOS ISO from last year (I think) which I was able to start up just fine, and I’ve also successfully booted up a Fedora ISO. Starting the computer like normal works fine as well, no issues. I’ve found some people around the internet who’ve run into vaguely similar problems, but nothing exactly like it.

Anyone got any ideas?

How much RAM does this Macbook Pro have?
Is it among of these?

It’s got 8 GB, upgraded from the original 4 GB. I think it’s a model 8.1, which would put it between 3 and 4 on that timeline.

how is the install medium created?
I saw this error poping up from time to time mostly caused by using old ventoy usb or old usb drives and also in cases apps like rufus or etcher …

Which one of these?

MBPs from 2011:

MacBook Pro “Core i5” 2.3 13" Early 2011 2.3 GHz Core i5 (I5-2415M)
MacBook Pro “Core i7” 2.7 13" Early 2011 2.7 GHz Core i7 (I7-2620M)
MacBook Pro “Core i7” 2.0 15" Early 2011 2.0 GHz Core i7 (I7-2635QM)
MacBook Pro “Core i7” 2.2 15" Early 2011 2.2 GHz Core i7 (I7-2720QM)
MacBook Pro “Core i7” 2.3 15" Early 2011 2.3 GHz Core i7 (I7-2820QM)
MacBook Pro “Core i7” 2.2 17" Early 2011 2.2 GHz Core i7 (I7-2720QM)
MacBook Pro “Core i7” 2.3 17" Early 2011 2.3 GHz Core i7 (I7-2820QM)
MacBook Pro “Core i5” 2.4 13" Late 2011 2.4 GHz Core i5 (I5-2435M)
MacBook Pro “Core i7” 2.8 13" Late 2011 2.8 GHz Core i7 (I7-2640M)
MacBook Pro “Core i7” 2.2 15" Late 2011 2.2 GHz Core i7 (I7-2675QM)
MacBook Pro “Core i7” 2.4 15" Late 2011 2.4 GHz Core i7 (I7-2760QM)
MacBook Pro “Core i7” 2.5 15" Late 2011 2.5 GHz Core i7 (I7-2860QM)
MacBook Pro “Core i7” 2.4 17" Late 2011 2.4 GHz Core i7 (I7-2760QM)
MacBook Pro “Core i7” 2.5 17" Late 2011 2.5 GHz Core i7 (I7-2860QM)

I’ve owned the third one on the list and never managed to get EnOS (or pure Arch) running on it. :frowning_face:

Fedora and all Deb based distros run fine.

P.S. - Not willing to disable the on-board Intel graphics.

1 Like

I’ve tried a couple of different methods. I started off using Ventoy, and then I tried Fedora Media Writer followed by Gnome Disks. I also tried Etcher, installed via Distrobox. Most of my attempts were with Disks. The USB drive I’ve used the most is pretty old at this point, though it seemed to start up Fedora okay, and I’ve since used it to install Gecko Linux. Maybe Arch-based distros are different?

By the way, since I managed to start an older EndeavourOS ISO back a few days ago, I tried downloading some older ISOs. Those also produce the same error now. That first install medium was a leftover from when the computer was still on EnOS, though. I only used Etcher back then.

Not sure it’s related, but I found myself looking at the GitHub page for EndeavourOS-ISO, specifically the boot options section. All my failed attempts are preceded by a menu that looks like the systemd-boot screencap, but the bios-boot menu strikes me as more familiar. I can’t really double check at this stage, but I feel like the bios-boot menu is what I got when that old install medium worked. Could there be anything to that?

From what I can tell, it’s the one with the I5-2435M. EndeavourOS has installed just fine in the past, multiple times. Also had Manjaro on it for a while. This is a new problem.

Have you tried the latest Nova release?

Edit: Also what mirrors did you download it from as i had some other user have issue also and i ask them to try a different download mirror and it was okay then.

Yup, tried it. So far, I’ve used the torrent, the GitHub mirror, the German Alpix mirror, and one of the Swedish ones.

i would check bios settings— could be it has secure boot enabled or you was having CSM legacy boot enabled before…and the firmware is causing issues on efi now…

You used this drive to install those systems on this particular Mac?
I noticed sometimes it is drive / port combination. For Chromebook I was not able to install from USB at all and had to use Micro SD disk.

For Macs, it seems like the secure boot function was introduced years after this model was made, so that shouldn’t be an issue - assuming we’re referring to the same thing. Based on what I’ve read so far, Macs don’t seem to have a way to access BIOS, or their equivalent. They activate legacy boot mode when they detect that a drive has an MBR partition table. According to a post by srs5694 on the Arch forum:

Macs manage BIOS/CSM/legacy-mode booting by using the partition table as a cue: If the disk contains either an old-style Master Boot Record (MBR) Partition table or a hybrid MBR, and if a partition in that MBR has its boot flag set, the firmware activates its BIOS/CSM/legacy support, enabling it to boot in BIOS/CSM/legacy mode. If the disk contains a GPT with a conventional protective MBR, or if no MBR partition is marked as bootable, the firmware will boot only in EFI mode.

Does EndeavourOS do anything unusual in this regard? It seems to be the only ISO I’ve tried so far that won’t start, including a plain Arch ISO.

1 Like

Pretty sure, yeah. First Manjaro, then EndeavourOS. At the very least, I’m certain that I’ve used this particular drive to reinstall EnOS on this particular Mac, probably in late 2021 or early 2022.

Video Card: HD Graphics 3000 VRAM Type: Integrated
Details: This model has an Intel HD Graphics 3000 graphics processor that shares memory with the system.

(From: everymac.com)

Perhaps, the Intel HD Graphics 3000 is not longer supported by Linux? Just guessing here.

Did you check the module-based options?

I’ve never messed with Arch pen-drive persistence, but there may actually be a way to get it done with an older kernel? :wink:

Okay, quick update. I decided to go further back in the ISO archive, and I’ve found that some of them work. So far, Atlantis Neo and Apollo have booted up successfully. Gonna try some of the Artemis releases as well.

That’s definitely possible, though wouldn’t that impact other distros as well? I actually haven’t looked at the module-based options. Are there any particular ones that might be helpful?

The Artemis ISOs seem to work, meaning that whatever the problem is, it seems to be specific to the Cassini ISOs. Assuming that I don’t manage to get any of the Cassinis working, would it be a bad idea to try to do an online installation of EndeavourOS from an Artemis ISO? My initial plan was to try EnOS’ setup for BTRFS. Would using an Artemis Nova ISO mess with that in any way?

An online installation would serve you the latest kernel via online-update, and render your system not bootable (most likely) after finishing the installation (if you are able to make it to the end, at all, as there will be several other hurdles on the installation high-way).


Sounds like a bad time! Would you guess that it’d be an EndeavourOS-specific issue, or something broader? The Mac is currently booting up without any apparent problems on Tumbleweed with a kernel designated “6.2.6-1 default”, which isn’t very old from what I can tell. Also, just so there’s no misunderstanding, when you say “not bootable”, do you mean in the sense that I’d have to reinstall Tumbleweed to get the computer to start properly again, or are we talking bricked to the point where I wouldn’t even be able to get it to install anything?

By the way, I really appreciate you guys helping me figure this stuff out!

just did install an artemis.iso – and it works :100: :enos: