Unable to share window in video-communication apps

Hello everyone! This is my first time posting on this forum.

I am having an issue where I am unable to share a window in video-communication apps (meet, zoom etc.)
I previously used Firefox, where I was only able to share my entire screen. The share tab and window sections were both blank. Then I switched to Chromium and the tabs became visible in the “share tab” section. This ability thus seemed like an app issue. But the “share window” section is still blank in all the browsers. This is the feature that I would like to enable somehow.
Through a few google searches, it seemed like using Wayland may be able to fix this issue. But my previous experience with KDE+Wayland has not been smooth. I faced some weird issues.
Is there any way through which I can enable “window sharing” feature specifically?

Thanks and regards

inxi -FAZ output:

  Host: AISHIK999 Kernel: 6.1.19-1-lts arch: x86_64 bits: 64
    Desktop: KDE Plasma v: 5.27.2 Distro: EndeavourOS
  Type: Laptop System: HP product: HP 255 G8 Notebook PC
    v: Type1ProductConfigId serial: <superuser required>
  Mobo: HP model: 87D1 v: 38.25 serial: <superuser required> UEFI: Insyde
    v: F.31 date: 06/16/2022
  ID-1: BAT1 charge: 39.4 Wh (99.0%) condition: 39.8/40.9 Wh (97.4%)
  Info: quad core model: AMD Ryzen 5 3500U with Radeon Vega Mobile Gfx
    bits: 64 type: MT MCP cache: L2: 2 MiB
  Speed (MHz): avg: 1377 min/max: 1400/2100 cores: 1: 1400 2: 1400 3: 1400
    4: 1400 5: 1400 6: 1400 7: 1223 8: 1400
  Device-1: AMD Picasso/Raven 2 [Radeon Vega Series / Radeon Mobile Series]
    driver: amdgpu v: kernel
  Device-2: Luxvisions Innotech HP TrueVision HD Camera type: USB
    driver: uvcvideo
  Display: x11 server: X.Org v: 21.1.7 driver: X: loaded: amdgpu
    unloaded: modesetting dri: radeonsi gpu: amdgpu resolution: 1366x768~60Hz
  API: OpenGL v: 4.6 Mesa 22.3.6 renderer: AMD Radeon Vega 8 Graphics
    (raven LLVM 15.0.7 DRM 3.49 6.1.19-1-lts)
  Device-1: AMD Raven/Raven2/Fenghuang HDMI/DP Audio driver: snd_hda_intel
  Device-2: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: snd_pci_acp3x
  Device-3: AMD Family 17h/19h HD Audio driver: snd_hda_intel
  Sound API: ALSA v: k6.1.19-1-lts running: yes
  Sound Server-1: PipeWire v: 0.3.67 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    driver: r8169
  IF: eno1 state: down mac: e0:70:ea:59:24:f1
  Device-2: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
    driver: rtw_8822ce
  IF: wlan0 state: up mac: 48:e7:da:ec:5d:47
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb
  Report: rfkill ID: hci0 rfk-id: 0 state: down bt-service: disabled
    rfk-block: hardware: no software: no address: see --recommends
  Local Storage: total: 1.6 TiB used: 20.6 GiB (1.3%)
  ID-1: /dev/nvme0n1 model: 256GB NVME EVM size: 238.47 GiB
  ID-2: /dev/sda vendor: Western Digital model: WD10SPZX-60Z10T1
    size: 931.51 GiB
  ID-3: /dev/sdb type: USB vendor: Samsung model: PSSD T7 size: 465.76 GiB
  ID-1: / size: 222.53 GiB used: 20.45 GiB (9.2%) fs: btrfs dev: /dev/dm-0
  ID-2: /home size: 222.53 GiB used: 20.45 GiB (9.2%) fs: btrfs
    dev: /dev/dm-0
  ID-3: /var/log size: 222.53 GiB used: 20.45 GiB (9.2%) fs: btrfs
    dev: /dev/dm-0
  ID-1: swap-1 type: partition size: 14.96 GiB used: 0 KiB (0.0%)
    dev: /dev/dm-1
  System Temperatures: cpu: 58.2 C mobo: N/A gpu: amdgpu temp: 58.0 C
  Fan Speeds (RPM): N/A
  Processes: 263 Uptime: 33m Memory: 13.6 GiB used: 1.96 GiB (14.4%)
  Shell: fish inxi: 3.3.25

Hi, welcome to the purple side of the force :enos:

Check if this link can help you: It’s for Gnome but perhaps can help you with KDE too.

Hi! Thanks for the reply
It seems like installing plasma-wayland-session and choosing wayland as WM on login, fixes the issue. But as I said previously, my past experience with wayland has not been so smooth on KDE.
But fortunately, this time atleast, I didn’t face any issues yet and can use all the screen sharing features over video communication services.

Thanks for the help :smiley:


Welcome to the EndeavourOS forum. I hope you enjoy your time here.

If you consider this Topic as solved, go to the post that most helped you solve the problem. Perhaps mcury’s Post 2, then hover over the box with a check mark in it.
“Select if this reply solves the issue” then click it.

This will show this Topic as Solved, and trigger the forum software to do it’s procedures.


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.