Unable to share screen in zoom

I’m using gnome desktop Environment 40.2.When i try to share my screen on zoom display this message.how to solve this?


my systems specifications are below

The short term solution is to log out and log back in using the “Gnome on X11” session. (Look for a little gear icon near the password prompt to change sessions.)

The long term solution is to file a bug report with the makers of zoom. It appears that EndeavourOS is not showing up on the Wayland supported list. It should, as it supports Wayland with Arch Linux.

There is no need to list EndeavourOS separately. If Arch is supported, so is EndeavourOS, because there is absolutely no difference between the two (except for branding, installation process, and this forum).

There should be no need, except that Zoom is apparently testing a bit of branding that results in the OS being reported differently in Arch and EndeavourOS. For example, in neofetch:

Arch Linux: OS: Arch Linux x86_64
EndeavourOS: OS: EndeavourOS Linux x86_64

Apparently, that small difference is causing the hiccups.

What does neofetch have to do with any of this?

neofetch simply prints whatever is in /etc/lsb-release under DISTRIB_DESCRIPTION.

Make an experiment for me, please, and edit your /etc/lsb-release to this (make a backup first, of course):

LSB_VERSION=1.4
DISTRIB_ID=Arch
DISTRIB_RELEASE=rolling
DISTRIB_DESCRIPTION="Arch Linux"

There, you have turned EndeavourOS into vanilla Arch, and nobody can tell the difference (well, unless they look really closely).

Does zoom screen share magically start working now? I somehow doubt it, but I would be happy to be wrong.

zoom only have a list of supported distributions so a bug report at zoom would be good to go, depending on where toom reads the distro info from /etc/lsb-release could work for sure, but any update of lsb-release will call eos hook that change it back :wink: (arch say we have to change that file)
also reinstalling lsb-release will set it back to EndeavourOS .

But it seem zoom reads /etc/os-release (also modified with hook for EndeavourOS)

I’m part of a corporate package so I’ve just reported this and will see how it goes.

Our place on distrowatch might even be useful for once. :wink:

They listened but I don’t think my single report will make anything happen swiftly.

I have sent the following using this link, anyone else who wants to help feel free to use my text.

I am hoping you can add Endeavour OS to your list of OS that allow wayland on GNOME.

I’m running Endeavour OS which is an Arch based distro that would work fine as Arch, Manjaro and Antegros are all supported. I’m hoping you could add it to the distros that are allowed to screen share on wayland.
https://endeavouros.com/

If you look at Distrowatch it is reasonably well known. ( number 2 :wink: )
https://distrowatch.com/

Just to add I have tested it by altering os-release to the one from arch and it works fine with that spoofed. I will include the os-release for Endeavour OS as follows:

NAME=‘EndeavourOS’
PRETTY_NAME=‘EndeavourOS’
ID=endeavouros
ID_LIKE=arch
BUILD_ID=2021.08.27
ANSI_COLOR=“38;2;23;147;209”
HOME_URL=‘https://endeavouros.com
DOCUMENTATION_URL=‘https://discovery.endeavouros.com
SUPPORT_URL=‘https://forum.endeavouros.com
BUG_REPORT_URL=‘https://forum.endeavouros.com/c/arch-based-related-questions/bug-reports
LOGO=endeavouros

2 Likes

The strange thing is that I can’t even share my screen on gnome 40 xorg, it’s a flickering disco ball mess, it shares but there is something going on with the refresh rate or compositor.

Had the same going on with kde, the only way was to disable desktop effects via Fn+F12 on kde. Not sure how to fix on gnome.

I need to login to my i3 wm session and no such problem. Screensharing works.

I actually use KDE and haven’t had any issues with zoom screen sharing with X11.

I use it 20 hours a week, so I’d be curious which effects are causing the issue.

I used vanilla kde.

Not much time to play around with settings since I use my linux computer at work and zoom too. I tried disabling a couple of effects without luck. The fastest was disable them all for my zoom calls. In the meantime I switched over to gnome for the past two months or so.

I believe no such problems in xfce but I will test again on this x1 lenovo and then on other thinkpad to rule out clash with new graphics hardware (intel Xe). Although its all integrated graphics, nothing too fancy.

Thanks for doing it.
I have also sent a request using the link.
Question: how/what did you spoof? When I opened /etc/os-release I got the very same text you list above, in which arch appears as “ID_LIKE” - yet, it is not working for me. What text did you change?

copy paste the one from archlinux in:

Thanks! @joekamprad
Let’s hope Zoom developers hear us.