Unable to select BTRFS instead of EXT4 during installation

I was going for the dual boot installation with Windows 10 and I selected replace partition, no swap, btrfs. The installer automatically set the file system to ext4 instead of btrfs when I clicked on the unallocated space. Is that expected behavior or a bug? I started installation with the one with NVIDIA.

Certain actions reset the settings on the page. You should just be able to change it to btrfs again before going to the next screen.

Thanks for the reply. Unfortunately, I realized it once everything was installed and attempted to take the timeshift btrfs snapshot. I have also seen this behavior on Arco linux or maybe it is the calamares way. I have tried again but same the result. It shows me btrfs but setup with ext4 no matter what I do.

Apologies for the low qualities images.