Unable to see usb drive in bios boot options

I recently installed endeavour os using manual partitioning. Everything seemed to work fine until I tried creating a bootable usb using etcher. The usb drive never shows up in the bios boot options. I can only see 2 options in bios boot

  1. Linux Boot Manager
  2. The drive which has endeavour os installed

Not sure what the issue is and why the usb is refusing to show up in bios boot options (I tried both etcher and dd to create a bootable usb)

Have you turned secure boot off?

Yeah, secure boot is disabled

Some BIOS firmware has options for USB. Look into the BIOS options/pages for a similar setting.

Had a look around the BIOS options, unfortunately nothing related to USB in there

Welcome to the forum! :smile:

Does command

lsblk -fm

show the drive?
If not, plug the drive to another USB port if possible, and try again.

Hi Manuel,

Attached output, the usb disk does show up

Looks like Cassini neo USB installer. How did you create it?
If you created it with the dd command, then it is not formatted like ordinary disks.
What do you want to do with that USB drive? Do you want to use if for another purpose?

Yeah correct this has the Cassini neo iso on it. I used etcher to create the same.

I distro hop sometimes, so was just trying to mess around (try different distros) and noticed that the usb drive is no longer showing up in the Boot Order on this particular endeavour os install of mine. In the past the usb drive used to show up perfectly fine.

So just confused as to what went wrong

If you have another USB drive, I assume it shows up?

I don’t have another USB drive lying around, but if you see the above screenshot I shared, I flashed one of my system drives (256 GB ssd) as well with the iso, but again that system drive didn’t show up in the bios boot options

The drive I am referring to is nvme0n1

If the USB drive can be formatted (you don’t directly need the ISO), you use gparted to create a partition table (gpt or msdos), then create a partition, and format it to e.g. ext4.

Does it show up after that?

I formatted the usb like you said (created a gpt partition table and formatted it to ext4), still it does not show up in bios boot order

Test the usb drive on another PC.

Look into the User Manual for a relevant setting.

If you didn’t install a bootloader to the drive, it doesn’t have anything to boot with.

IIRC this shouldn’t stop BIOS to show the USB drive. That’s why we sometimes see errors like “Could not find bootloader”, or skipping entries that can’t boot and try the next entry in order. IIRC, as I said… :slightly_smiling_face:

Haven’t tested this for a long time, but if I remember correctly, some drives were not visible in the BIOS boot menu if they didn’t contain any kind of bootloader.
Would need some testing…

Edit: but then again, the ISO installer should have been visible. Maybe the drive has some hardware issue?

1 Like

This is still an issue and it’s clearly has something to do with EOS as if I delete all boot entries involving EOS then the drive appears as it should.

You are commenting in someone else’s topic. Different systems (vendor, model, etc) are different in how HW and firmware are programmed to communicate with each other.
Assuming that this issue is the same with yours, without providing your own HW/SW setup is almost meaningless.

If you are experiencing a similar issue, it would be better to start a new topic and provide any relevant info, so someone may help you find the source of the problem and hopefully a solution.