Unable to rename desktop shortcuts?

As per the title - I’m not sure if this is just a limitation in the way shortcuts work in a Linux environment (I’ve only been using Endeavour for a couple of months so I’m still very new!) or if I’ve got a setting incorrect somewhere, but for example -

The shortcut to my steam installation is called “Steam (Native)” - if I try to rename it to simply “Steam” on my desktop, I get the error message:

“Could not rename file /home/(username)/Desktop/Steam.desktop.”

If I open the Properties menu and attempt to change the name in the Application tab, I get the error message:

“Could not save properties due to insufficient write access to:

It’s not a dealbreaker if I simply can’t rename it so feel free to tell me so if that’s the case :smiley: , but since I’ve decided to stick with Endeavour I’d at least like to try understanding a little more about how things work :slight_smile:

1 Like

What says: ls -al /home/(username)/Desktop/Steam.desktop?

Most probably the file is owned by root.

1 Like

Thanks for the reply! The output I get for that command may be a little awkward to read because I somewhat short-sightedly gave the laptop the same name as my username, so I’m not sure if any of the below is referring back to the laptop itself rather than the account but it comes back with:

lrwxrwxrwx 1 (username) (username) 44 Jun 13 21:12 /home/(username)/Desktop/Steam.desktop → /usr/share/applications/steam-native.desktop

/home/(username)/Desktop/Steam.desktop seems just to be a link to /usr/share/applications/steam-native.desktop which is a file owned by root.

I am not sure if this is the best approach but this is what I would try:

cp /usr/share/applications/steam-native.desktop ~/Desktop/

Edit this latter file in ~/Desktop. If you get it working the way you want remove that Steam.desktop link.

1 Like

That’s worked! Thank you.

Comparing the output from this to the original one I was using, it seems like if you right click a program directly from the menu and choose the “Add to Desktop” option it’s creating an actual link directly to the executable (I imagine there’s a proper name for this rather than my entirely uneducated rambling :D) rather than a ‘shortcut’ as I’d recognise it from a Windows environment, which is how the method you’ve given seems to work.

It would be nice if the default behaviour on the system worked the same way so I could just use the right click menu, but like I said it’s a problem I can live with :slight_smile:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.