Unable to open Steam

I have been using EndeavourOS for a couple of years and things were going very well. I have been using steam all the time during that period. But for the last couple of days I am unable to open steam. When I tried opening it from terminal, it showed this error message.

steam.sh[60063]: Running Steam on endeavouros rolling 64-bit
steam.sh[60063]: STEAM_RUNTIME is enabled automatically
setup.sh[60138]: Steam runtime environment up-to-date!
steam.sh[60063]: Steam client’s requirements are satisfied
[2023-07-27 01:42:55] Startup - updater built Jul 10 2023 23:58:24
[2023-07-27 01:42:55] Startup - Steam Client launched with: ‘/home/samya/.local/share/Steam/ubuntu12_32/steam’
07/27 01:42:55 Init: Installing breakpad exception handler for appid(steam)/version(1689034492)/tid(60192)
SteamUpdateUI: An X Error occurred
X Error of failed request: BadValue (integer parameter out of range for operation)

Any help will be much appreciated on how to fix this. :grinning:

I can’t help you with the error, but in the past I ran into similar situations such as this with steam and most of the time I had to remove and reinstall to get it working again which I grew tired of. So eventually I installed steam as a flatpak and after doing so I have had no problems at all with steam, everything just works. Here’s a great tutorial on how to do that https://steamcommunity.com/sharedfiles/filedetails/?id=2615011323 .

You might be able to copy some of your files over from your normal steam installation to the flatpak steam installation which you can find at /home/YOURUSERNAME/.var/app/com.valvesoftware.Steam/, such as steamapps for flatpak steam it’s located at /home/YOURUSERNAME/.var/app/com.valvesoftware.Steam/.steam/steam/steamapps/ where you don’t have to re-download all your games again.

When I installed steam flatpak I just went with a fresh install and didn’t copy anything over so I can’t say whether that will work or not for sure but it might be worth a try.

It’s a good idea to run flatpak update from time to time in terminal.

Anyway, just thought I would mention this in case it might help you. Good Luck!