Unable to install on main pc

Hello :slight_smile:

After testing on laptop, tried installing on main pc, but unfortunately every boot results in total freeze about 4 seconds in. There wasn’t time to quickly change the kernel, so the kernel was whichever was downloaded during net install for Mate. I’ve reinstalled Anarchy at this point, but, if more hardware details are helpful, I can post that. Could it be that some extra installs and/or settings, caused one or two issues e.g. about speed, and with recent hardware?

Ryzen 7 3800X, Radeon RX5700XT

Hello @northernlass
I’m not sure what is causing your freeze. It could be the RX5700XT. I have the Ryzen 7 3800X with Radeon RX590 and no issues. I am wondering what some of your other hardware such as the motherboard? Are you able to post the following?

inxi - FGz

Edit: Do you have two separate power supply lines going to the video card?

1 Like

Hi @ricklinux and thank you for your message :slight_smile: Yes, the Ryzen 7 3800X runs very well. I have an RX560 on the laptop which is fine, as you’re saying about your RX590. The laptop install on Endeavour is very good. The RX5700XT is running fine on Anarchy at this point, so it would be great to find the difference.

I’m not sure about the two power supply lines, but it does look as if there are two big ‘caterpillar’ cables running between the GPU and, if that’s a PSU at the top, lol, the PSU.

The PC is from PCSpecialist, a Fusion Extreme. The motherboard is an ASUS® TUF X570-PLUS GAMING (USB 3.2 Gen 2, PCIe 4.0, CrossFireX) - RGB Ready, with a 1TB SEAGATE FIRECUDA 520 GEN 4 PCIe NVMe (up to 5000MB/R, 4400MB/W) and 850w PSU.

inxi -FGz

System:    Kernel: 5.7.6-zen1-1-zen x86_64 bits: 64 Desktop: MATE 1.24.0 Distro: Arch Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: TUF GAMING X570-PLUS v: Rev X.0x serial: <filter> 
           UEFI: American Megatrends v: 1405 date: 11/19/2019 
CPU:       Topology: 8-Core model: AMD Ryzen 7 3800X bits: 64 type: MT MCP L2 cache: 4096 KiB 
           Speed: 4216 MHz min/max: 2200/4200 MHz Core speeds (MHz): 1: 4183 2: 4197 3: 4206 4: 4175 5: 4201 
           6: 4205 7: 4195 8: 4199 9: 4204 10: 4201 11: 4197 12: 4237 13: 4196 14: 4201 15: 4195 16: 4185 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT] 
           driver: amdgpu v: kernel 
           Display: x11 server: X.Org 1.20.8 driver: ati,modesetting unloaded: radeon resolution: 
           1: 1920x1080~60Hz 2: 1920x1080~60Hz 
           OpenGL: renderer: AMD Radeon RX 5700 XT (NAVI10 DRM 3.37.0 5.7.6-zen1-1-zen LLVM 10.0.0) 
           v: 4.6 Mesa 20.1.1 (git-951983c483) 
Audio:     Device-1: Advanced Micro Devices [AMD/ATI] Navi 10 HDMI Audio driver: snd_hda_intel 
           Device-2: Advanced Micro Devices [AMD] Starship/Matisse HD Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k5.7.6-zen1-1-zen 
Network:   Device-1: Realtek RTL8192EE PCIe Wireless Network Adapter driver: rtl8192ee 
           IF: wlp4s0 state: down mac: <filter> 
           Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169 
           IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
           IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
Drives:    Local Storage: total: 17.34 TiB used: 15.51 TiB (89.5%) 
           ID-1: /dev/nvme0n1 vendor: Seagate model: FireCuda 520 SSD ZP1000GM30002 size: 931.51 GiB 
Partition: ID-1: / size: 907.71 GiB used: 45.52 GiB (5.0%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: /boot size: 510.0 MiB used: 71.9 MiB (14.1%) fs: vfat dev: /dev/nvme0n1p1 
Swap:      ID-1: swap-1 type: partition size: 7.81 GiB used: 0 KiB (0.0%) dev: /dev/nvme0n1p3 
Sensors:   System Temperatures: cpu: 46.6 C mobo: N/A gpu: amdgpu temp: 40 C 
           Fan Speeds (RPM): N/A gpu: amdgpu fan: 0 
Info:      Processes: 327 Uptime: 2h 19m Memory: 31.34 GiB used: 2.75 GiB (8.8%) Shell: bash inxi: 3.1.03 

I also have an Asus Tuf board running an Intel 8086k 5.0 Ghz Anninversary processor with Nvidia GTX 1060 no issues. The RX 5700XT is a step up.

I see you need to update the UEFI Bios on your Motherboard. You are running version 1405 dated 2019/11/26. There is a newer version. You want to update to the latest current version which is 2203 dated 2020/06/29. If you are unfamiliar with updating the UEFI Bios please read the instructions. I recommend download the files to a usb and using the manual update process from the UEFI update screen.

When you loaded EndeavourOS did it freeze like right away? Not usable at all. Did you load anything other than the default install?

Edit: Hardware looks really good.

1 Like

I am looking at you CPU settings above? Are you overclocking? The Ryzen 7 3800X is 3.9 Ghz base to 4.5 Ghz. Do you have the core settings changed? The reason i ask is because this is mine on default settings.

CPU:       Topology: 8-Core model: AMD Ryzen 7 3800X bits: 64 type: MT MCP L2 cache: 4096 KiB 
           Speed: 2700 MHz min/max: 2200/3900 MHz Core speeds (MHz): 1: 1861 2: 1865 3: 1860 
           4: 2800 5: 2193 6: 2194 7: 2193 8: 2191 9: 1863 10: 2797 11: 2203 12: 2197 13: 2199 
           14: 2198 15: 1866 16: 1861 
1 Like

Okay… i checked my settings and you must be running game boost.

CPU:       Topology: 8-Core model: AMD Ryzen 7 3800X bits: 64 type: MT MCP L2 cache: 4096 KiB 
           Speed: 4250 MHz min/max: N/A Core speeds (MHz): 1: 4250 2: 4243 3: 4246 4: 4251 
           5: 4245 6: 4249 7: 4249 8: 4252 9: 3852 10: 4226 11: 4227 12: 4226 13: 4247 14: 4247 
           15: 4225 16: 4232 
1 Like

Thank you for your very helpful posts, and it’s great that your Nvidia doesn’t have any issues.

I’d updated the bios about 6 weeks ago and had some issues. I did it via internet option, I think, and then reverted using the USB method, which, you’re right, is much better. Am a little bit not wanting to change the bios, with things running fine on Anarchy, tbh, but appreciate advice and will give it some thought; hadn’t checked about any new bios’s, and things might be even better via updating, so thanks for drawing attention to that.

Yes, it froze immediately; about 4 seconds in, every time I tried. Nothing useable. I’d used the net install to install Mate and printer support.

And thank you about hardware! The previous main pc keeled over suddenly about 3 months ago, so I decided to go full AMD and buy something that would last a long time. 1st purchase from PCSpecialist and it’s really good. Where did you get your system from, or did you build it?

And I’d never have known the clock was set higher if you’d not noticed, lol. I’d not selected overclocking in the order, and have just seen your additional post. I didn’t know there was game boost either … I should go and check the bios, lol, as I may have turned on something boostie. Thanks for checking about that. Your setting will be good for less wear and tear I’d think.

Eeek, I can’t access Asus’s bios list or download … the message reads ‘ASUS recommends Windows 10 Pro for business’, lol. I’ve turned off all blockers and still no-go. Was going to see what the bios update was. Waterfox Classic. Will try non-blockered Current … can access it there.

I’m not sure what settings are on the Asus X-570 but my board is an MSI MPG X570 Gaming Plus and it has Game Boost. I turned it on and got almost identical settings so the Asus must have something similar.
On my Tuf Z370 Intel board which is also a gaming Pro i have updated the UEFI Bios to current version which happens to be the same number but most likely different coding as it is an Intel Z-370 not an X-570 AMD.

1 Like

I only use Firefox.

1 Like

I just realised, it wasn’t the new main PC I updated the bios on, but the laptop I was using just before it arrived, which I see isn’t supported now by Asus (FX505DY). I don’t actually know how to update the main PC’s bios, with it coming from PCSpecialist, especially if I needed to downgrade if there were issues. :thinking:
Will take a quick look at bios, to see if boost switched on …

EDIT: it was set to ‘customised’ so I’d toggled something. Of course clicking it set it to ‘normal’ and I can’t remember the customised stuff, lol. So, I took the leap and updated the bios over the internet anyway … nerve-wracking stuff, lol. :joy:

System:    Kernel: 5.7.6-zen1-1-zen x86_64 bits: 64 Desktop: MATE 1.24.0 Distro: Arch Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: TUF GAMING X570-PLUS v: Rev X.0x serial: <filter> 
           UEFI: American Megatrends v: 2203 date: 06/17/2020 
CPU:       Topology: 8-Core model: AMD Ryzen 7 3800X bits: 64 type: MT MCP L2 cache: 4096 KiB 
           Speed: 2383 MHz min/max: 2200/3900 MHz Core speeds (MHz): 1: 2586 2: 2119 3: 2105 4: 2106 5: 1862 
           6: 1857 7: 2789 8: 1856 9: 2120 10: 2123 11: 1863 12: 1861 13: 2791 14: 1861 15: 2260 16: 2097 

Mine’s lower than yours now. :smile: Maybe best to boost it up if games show any effect from leaving the setting on normal.

It looks more like my default settings now on the X-570 board. Doing the update over ethernet is not so bad. It’s wifi that’s not a good idea. Anyway all i can say is i don’t know why it works okay on Anarchy which is an Arch installer like EndeavourOS. You’d have to look at what’s installed.

check

pacman -Q | grep amd

pacman -Q | grep mesa

pacman -Q | grep vulkan

1 Like

Yes, ethernet seems much more stable all-round, definitely. I’ve done installs on this Anarchy install, so the results won’t be clean, but things were running fine on the fresh install, before adding anything.

pacman -Q | grep amd
amd-ucode 20200519.8ba6fa6-1

pacman -Q | grep mesa
lib32-mesa-aco-git 20.1.1.20200611.951983c483a-1
mesa-aco-git 20.1.1.20200611.951983c483a-1
mesa-demos 8.4.0-4

pacman -Q | grep vulkan
lib32-vulkan-icd-loader 1.2.141-1
vulkan-icd-loader 1.2.141-1
vulkan-tools 1.2.141.0-1

I had watched the Endeavour install and seen a few packages going through that aren’t normally on the system eg the video-vesa driver, nvidia, nouveau, broadcom.

I don’t see the amdgpu driver? xf86-video-amdgpu 19.1.0-2

Nouveau is the open source driver for Nvidia
Broadcom is for Wireless
video-vesa is just vesa driver for video

1 Like

You’re right. I just double-checked and it’s not installed. The Anarchy installer suggest AMD/ATI as best, installs it’s stuff, and that usually works. I’m looking for a package list for clean Anarchy … have seen a few people saying about freezes with AMD cards, so maybe it’ll be helpful to see.

Here’s a compare of Anarchy and EndeavourOS packages …
https://distrowatch.com/dwres.php?firstlist=anarchy&firstversions=0&resource=compare-packages&secondlist=endeavour

When i have installed Anarchy i chose amdgpu so i probably get it. But anyway this is what installs with EndeavourOS. So I’m not sure what to suggest to you.

1 Like

Good that it worked for you. I can see that Endeavour add e.g. gcc, nvidia, qt, samba, and xfdesktop. Not sure if any of those could have any possibility of being involved in the freezing, but I’m wondering if maybe the nvidia package could be optional in the installer? I was going to ask if lxdm itself could be included as an option … the ‘switcher’ is genius, but it could be cool to have lxdm as an install option.

Thanks for spending so much time on this. Really appreciate.

There’s nothing here that i see is an issue. Both will install the latest kernel. The normal driver for the card is amdgpu which is automatically loaded and mesa. Then you can add other drivers for gaming such as 32 bit for steam etc.

I’m not sure; it’s certainly a mystery, but thanks for looking into it. Great to have updated the bios. If I find anything more that may be helpful, I’ll add it. :smiley:

1 Like

I think now that you have updated the Uefi Bios and set the settings to default you would have to install EndeavourOS again and see. You need to try to get some more information when it’s booting if it fails. I would recommend installing the Xfce desktop.

Here is info on the amdgpu.

https://wiki.archlinux.org/index.php/AMDGPU#Installation

1 Like