Unable to install latest R3 version

I’m unable to install the latest R3 version because I keep running into an error that I do not fully understand nor can fix.

This is the error in question

Which tool did you used for making bootable usb ? If Ventoy, try Rufus or Mintstick or others

I had the same error with Ventoy

I made use of WoeUSB, but I’ve actually just realised that this is specifically for making bootable drives with Windows :person_facepalming:, so I’ll check out Mintstick or balenaEtcher (I wanted to use rufus at some point but I see the app only works on Windows, and I’m still on linux in this case haha)

1 Like

balenaEtcher or Fedora Media Writer are my two suggestions if you’re in Windows. On Linux - whatever you want, there’s a bunch of options.

1 Like

Booting in Grub2 mode should work fine with Ventoy.

Warning! we do not recommend using etcher anymore as there are privacy concerns, etcher is Anonymously reporting errors and usage information. It is not clear if this is done. Also, it wants you to validate that you agree with it. Lately, users reporting also burned sticks does not work properly for the latest ISO.

Currently (December 2021) etcher is not able to create USB from our ISO anymore, it fails and gives an error about compression.


1 Like

If your using Windows though there are already privacy concerns, I ended up using etcher the other week when I got a new PC that had windows on it and it worked just fine. Though I did try a couple of other tools they couldn’t create it on my portable HDD were etcher could and it was the only medium I had available. Though on Linux my go to is almost always suse image writer.

So, I guess the only option on Windows is Fedora media writer then. I just knew it worked and security is already a joke anyways.

Ventoy also can be installed from Windows. It is very reliable and easy to use. Someone mentioned it did not work for them, but I have used it for years on many devices and never had an issue with an EOS ISO. :man_shrugging:

Huh, okay, it’s the first I’m hearing about this. Thank you for the notes! I will use a different writer then :slight_smile:

Regarding this forum thread, since I ended up figuring out what my issue was (using WoeUSB when it’s specifically for windows iso’s), is there a way I can close it without making a “solution” for it, or do I have mark something as the solution?

First, test that you can now successfully complete the installation.

If using “something else” was all that was needed to resolve the issue, perhaps post #2 should be marked as the solution. That is the post where trying something else was first suggested:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.