Unable to install Imaginary-teleprompter

I can’t satisfy the dependencies when I try to install “Imaginary-teleprompter-bin 2.3.4.13” on my new laptop. Needless to say I’ve had the same program installed on another laptop 3 months ago without any problem.
I get the following error message:
could not satisfy dependencies:
unable to satisfy dependency ‘libappindicator-sharp’ required by imaginary-teleprompter-bin

I tired ‘yay -S imaginary-teleprompter-bin’, which didn’t work. Also tried to install ‘libappindicator-sharp’, but nothing shows up on that either.
Tried AUR, and didn’t work.
What am I missing?

You could search AUR packages here: https://aur.archlinux.org/packages
There they have lots of information about all AUR packages.

https://aur.archlinux.org/packages/teleprompter-git/www.imaginary.tech/teleprompter

Last Updated: 2017-05-22 01:48

PKGBUILD have a not working git-url…

you will need to change this in the PKGBUILD:

source=('teleprompter-git::git+https://github.com/ImaginarySense/Teleprompter-Core.git')

after this build should work, i have build a package without issue:

http://endeavour.kamprad.net/packages/teleprompter-git-r211.d2a376d-1-any.pkg.tar.xz

https://aur.archlinux.org/packages/imaginary-teleprompter-bin/

Last Updated: 2018-04-07 22:17

libappindicator-sharp 12.10.0-13 is no longer available

libappindicator-sharp 12.10.0-13 has been removed from the [community] repository.

Unfortunately, this package cannot be found in any other repositories.

so missing dep makes it uninstallable… would need to solve dependency first…

you have to check if there is an equivalent to your software or at worst go to the site of the original software

@joekamprad

I installed all the required packages mentioned and ran your “pkg.tar.xz” script, and it was installed successfully, but I’m still getting the ‘missing dependencies message’, and of course as you mentioned “libappindicator-sharp” is no longer available. Could you tell me how you installed it, and thanks for taking the time doing this, as it’s little above my head!

this is a package you can install by 'sudo pacman -U teleprompter-git-r211.d2a376d-1-any.pkg.tar.xz`

I do simple download the Source from AUR modify the PKGBUILD and build by hand makepkg -si

I have “teleprompter-git-r211.d2a376d-1-any.pkg.tar.xz” in my download folder.
I did the following:
cd Download
sudo pacman -U teleprompter-git-r211.d2a376d-1-any.pkg.tar.xz
It was installed, but I’m still getting the same missing dependencies message.
What am I doing wrong?

[fred@EnToshiba ~]$ cd Downloads
[fred@EnToshiba Downloads]$ sudo pacman -U teleprompter-git-r211.d2a376d-1-any.pkg.tar.xz
[sudo] password for fred:
loading packages…
warning: teleprompter-git-r211.d2a376d-1 is up to date – reinstalling
resolving dependencies…
looking for conflicting packages…

Packages (1) teleprompter-git-r211.d2a376d-1

Total Installed Size: 0.03 MiB
Net Upgrade Size: 0.00 MiB

:: Proceed with installation? [Y/n]
(1/1) checking keys in keyring [----------------------------] 100%
(1/1) checking package integrity [----------------------------] 100%
(1/1) loading package files [----------------------------] 100%
(1/1) checking for file conflicts [----------------------------] 100%
:: Running pre-transaction hooks…
(1/1) Creating Timeshift snapshot before upgrade…

/dev/dm-0 is mounted at: /run/timeshift/backup, options: rw,relatime,discard


Creating new snapshot…(RSYNC)
Saving to device: /dev/dm-0, mounted at path: /run/timeshift/backup
Linking from snapshot: 2020-03-25_13-57-27
Synching files with rsync…
Created control file: /run/timeshift/backup/timeshift/snapshots/2020-03-25_14-05-19/info.json
RSYNC Snapshot saved successfully (12s)
Tagged snapshot ‘2020-03-25_14-05-19’: ondemand

:: Processing package changes…
(1/1) reinstalling teleprompter-git [----------------------------] 100%
:: Running post-transaction hooks…
(1/1) Arming ConditionNeedsUpdate…

On the homepage of that software there is a link for Arch downloads, which leads to Sourceforge. There you can download a file called imaginary-teleprompter-2.3.4-64bit.pacman. Filesize is 33,6 MB. I don’t have the time now to figure it out. But maybe that’s of some help for you.

Edit : Okay. Tried to install that one with pacman. Didn’t work. I get the same complaint about dependency. Maybe you should contact the developer. I wonder if the available snap package would work.

Now I was really curious and tried if I could get the snap package to work. It was a little bit more work than I expected but …

If you’re interested in installing it that way and you have any questions, just ask.

it only say it is checking for resolving dependencies…and conflicting packages and it is installing properly…

i do not see that libappindicator-sharp is a dependency for the git build:
https://aur.archlinux.org/packages/teleprompter-git/

may you have them both installed? bin and git version?

I’m not quite sure what I’m doing wrong. I have all the dependencies installed, and still getting the error. How ever, I found out during this process that you can run the program on any browser without downloading the actual program! https://imaginarysense.github.io/Teleprompter-Core/
Therefore no need having the program installed on your computer.
You can also download a sefl contained executable image app on your computer, So really no need for all this headache! Thanks you for all your effort and help. You guys are awesome!

1 Like