Unable to install Goverlay

Hello! New user here. I’m having trouble getting goverlay installed. It keeps giving me error messages when it gets to the point where it’s compiling mangohud. Here is the error message it ends at:

[54/104] Compiling C++ object src/libMangoHud.so.p/dbus.cpp.o
ninja: build stopped: subcommand failed.
==> ERROR: A failure occurred in build().
→ error making: mangohud (mangohud-common mangohud)

I’m running a 5800x3d and 7900 xtx. I’m running the KDE version of Endeavour. It’s a fresh install and fully updated. As I said, I’m new here, so I’m not really sure where to begin or how to fix this. Thank you!

3 aur/goverlay-bin 0.9.1-2 [+47 ~4.24]
    A GUI to help manage Vulkan/OpenGL overlays

There is a binary version, try that. I have the Chaotic and Arch China repos enabled and it installs fine, but mangohud is in Archlinuxcn, so of course it works!

What does it do?


community/fpc                3.2.2-6      343.79 MiB      41.73 MiB
community/fpc-src            3.2.2-3      289.13 MiB      30.30 MiB
community/lazarus            2.2.4-1      982.24 MiB     100.49 MiB
archlinuxcn/mangohud         0.6.8-5        1.31 MiB       0.59 MiB
archlinuxcn/mangohud-common  0.6.8-5        0.03 MiB       0.01 MiB

This is what I get… goverlay compiles fine.

I tried the binary version also. Still didn’t work. I will try to figure out how to add the different repos and see if that will allow me to install it. Thank you.

I figured out how to enable the chaotic-aur and installed goverlay from there. That worked! Thanks!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.