Unable to install EndeavourOS

EndeavourOS is something I’ve been able to install countless times before, and have used it exclusively for nearly 6 months straight this past year. I switched back to Windows for awhile, but now I can not get EndeavourOS to install. Hell, I can’t even get to the installation.

I tried to install it over a week ago, and am attempting to do so once more, but it’s just not happening. Whenever I load up the USB, I always end up on this screen here after all the text cycles through, with it not allowing me to type anything with my keyboard. The only thing I noticed is when starting up the USB when all the modules and whatever else are being enabled or whatever, I see the Nvidia module as failed, with it saying that it’s blacklisted. Not sure if that’s the issue, but like I said I can’t type anything with the keyboard to even try to figure out what’s going on.

What are the specific models for your CPU and GPU?

CPU is the Ryzen 7800X3D, motherboard is Asrock X670E Pro RS, and GPU is a 3080 ti.

It looks like you booted to the open source option. Choose the proprietary drivers from the boot menu.

It legit won’t even present me with the option.

All I see when I boot up the PC is black screen with white text _

Then after a bit of time it will go through all the modules and so on like in first post.

My guess is for some reason it’s not showing me the boot options, then after awhile with no input it just defaults to the first option.

i would reboot the computer and after the intial bios splash i would press the up or down arrow key and see if that shows you the boot menu

I think I found the problem, with that being the USB I was using to install these distros. I guess it’s finally gone to shit.

Like, it legit didn’t matter which distro I tried installing, whether it be Endeavour, Garuda, or Arcolinux I’d be met with a blank black screen, with EndeavourOS being the only one that’d eventually load, but I’m assuming that’s with it defaulting to the open source drivers that won’t work.

The only distros that I tried and could get to install was Fedora (and Nobara which is based on it), and I don’t like Fedora at all anymore.

Switching to a different USB seems to have solved my problem, with the USB loading properly now and presenting the boot options, as well as getting to the desktop for the install to take place.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.