Unable to get past bootloader

Dear all,

I recently decided to try endeavour. Worked fine running on the live usb. However, I’ve had issues since installing. After the bootloader it through a me out to terminal and gives me the following error messages:

PXL_20210430_200706532

Any ideas?

Many thanks in advance.

It seems to me the bootloader cannot find the drive you specified for the install. Did you use automatic partitioning or manual partitioning?

Yeah, that looks like the issue. If you used Calamares’ auto partitioning it is probably a Calamares bug you have discovered and you should report it. But if you did manual partitioning, most likely you forgot to do something like forget to set a mount point, used wrong filesystem, just forgot to set a size, etc…

Can you open the live iso and type lsblk, and send the output?

One more thing to try. If you don’t have a Windows install, go into your Bios, and see if you have a field for “disk mode”. If it is set to ACHI set it to Sata

Thanks for getting back to me. I used auto partitioning, not manual (Little above my skills!). I’ve tried looking in the bios but nothing like that there. From the lsblk I got the following:

[liveuser@eos-2021.04.17 ~]$ lsblk
NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT
loop0 7:0 0 1.7G 1 loop /run/archiso/airootfs
sda 8:0 1 28.6G 0 disk
├─sda1 8:1 1 1.9G 0 part /run/archiso/bootmnt
└─sda2 8:2 1 68M 0 part
nvme0n1 259:0 0 476.9G 0 disk
├─nvme0n1p1 259:1 0 512M 0 part
└─nvme0n1p2 259:2 0 476.4G 0 part
nvme1n1 259:3 0 27.3G 0 disk
└─nvme1n1p1 259:4 0 27.2G 0 part
[liveuser@eos-2021.04.17 ~]$

I have been having this issue with all the arch based distro’s I have tried. All the ubuntu and debian based distro’s have been fine. Very frustrating.

What i would do is boot up on the live ISO. Don’t start the installer. Use gparted to select the drive and click on device, create new partition table and create a new gpt partition. Then close gparted and start the installer and use erase disc or you could also do manual partitioning.

Edit: If you are not using the full disc and have important data on the disk be aware that this will erase the whole disc.

@williphant, please be aware this essentially erase all the data on that disk. If the disk in question has other important data, you should probably avoid this path.

1 Like

I wonder which drive is it installed on? nvme0n1 or nvme1n1?

can you provide

sudo lsblk -fs
sudo parted -l

PXL_20210502_142730352
PXL_20210502_142648792

Does that help?

Looks like you have two fat 32 partitions. What is the fat32Garuda?

Edit: The original post shows it has the wrong UUID

Edit2: Are you able to look at and change the fstab file in /etc/fstab to correct the UUID and then update grub with sudo grub-mkconfig -o /boot/grub/grub.cfg

Then it may boot properly.