Unable to get bullet points to render on onlyoffice

I am using onlyoffice on Linux.

On Debian based distros such as Linux Mint and Peppermint OS, when I open Microsoft office created documents such as this file (this is a sample file):

which is supposed to look like this:

bullet points fail to render and it looks like this:

Even though it shows that this text has bullet points.

However on EndeavourOS the bullet points show up just fine.

However the issue is that now I am having the same issue as on Linux Mint where the bullet points fail to render unless if I clear then and again put them back in. Both OSes used the exact same version of OnlyOffice.

Its not like libreoffice at all is having this issue. Its only on onlyoffice.

I have been installing various fonts so I don’t know if I have messed something up. I have previouslly tried out nerd fonts.

Currently in ~/.fonts I have consola.ttf (which is a Windows font). After copying it from my Windows computer to my Linux machine to this directory I ran fc-cache.

I also installed some emoji support:

sudo pikaur -S noto-fonts-emoji ttf-twemoji

and ran this:

sudo cp /usr/share/fontconfig/conf.avail/75-twemoji.conf /etc/fonts/conf.d/75-twemoji.conf

So eventually when I opened the same document file I am getting this issue where the bullet points are not rendering.

I tried to replicate the same thing on a virtual machine where I would at least install Microsoft fonts and the emojis (I haven’t tried the nerd fonts and all that as I can’t really remember what I exactly did) and yeah I am unable to replicate it on my VM (all though it I am using the MATE addition of EndeavourOS and I didn’t think xfce has anything to do with this).

Should I maybe try and delete onlyoffice’s dot files or something? Should I install another font pack or what should I check?