Unable to find a specific WiFi network

I’m sometimes unable to connect to a particular WiFi network. It doesn’t show up in available networks but if I do nmcli connect up, the connection goes through. No problem is there when I mark the network as hidden. But the network is not hidden, and it works properly with all other devices. Only this laptop has this problem, and with that specific network.

I’m not sure which logs to provide, so just providing system info. If anything else is needed, I’ll provide them ASAP. Thank you.

inxi -Fazy

  Kernel: 5.10.84-1-lts x86_64 bits: 64 compiler: gcc v: 11.1.0
  parameters: BOOT_IMAGE=/@/boot/vmlinuz-linux-lts
  root=UUID=792fd0e5-0942-45cc-b07b-400213890a85 rw rootflags=subvol=@ quiet
  resume=/dev/sdb2 loglevel=3 resume_offset=1840384 nowatchdog
  Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1
  dm: SDDM Distro: EndeavourOS base: Arch Linux
  Type: Laptop System: HP product: HP Pavilion Laptop 14-bf1xx
  v: Type1ProductConfigId serial: <superuser required> Chassis: type: 10
  serial: <superuser required>
  Mobo: HP model: 83CE v: 59.38 serial: <superuser required> UEFI: Insyde
  v: F.31 date: 10/30/2017
  ID-1: BAT1 charge: 36.9 Wh (87.2%) condition: 42.3/42.3 Wh (100.0%)
  volts: 12.3 min: 11.6 model: Hewlett-Packard PABAS0241231 type: Li-ion
  serial: <filter> status: Discharging
  Info: Quad Core model: Intel Core i7-8550U bits: 64 type: MT MCP
  arch: Kaby Lake note: check family: 6 model-id: 8E (142) stepping: A (10)
  microcode: EA cache: L1: 256 KiB L2: 1024 KiB L3: 8 MiB
  flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3
  bogomips: 31999
  Speed: 800 MHz min/max: 400/4000 MHz Core speeds (MHz): 1: 800 2: 800 3: 800
  4: 800 5: 800 6: 800 7: 800 8: 800
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported
  Type: l1tf mitigation: PTE Inversion
  Type: mds mitigation: Clear CPU buffers; SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: spec_store_bypass
  mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
  mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional,
  IBRS_FW, STIBP: conditional, RSB filling
  Type: srbds mitigation: Microcode
  Type: tsx_async_abort status: Not affected
  Device-1: Intel UHD Graphics 620 vendor: Hewlett-Packard driver: i915
  v: kernel bus-ID: 00:02.0 chip-ID: 8086:5917 class-ID: 0300
  Device-2: NVIDIA GM108M [GeForce 940MX] vendor: Hewlett-Packard
  driver: nouveau v: kernel alternate: nvidia_drm,nvidia bus-ID: 01:00.0
  chip-ID: 10de:134d class-ID: 0302
  Device-3: Chicony HP Wide Vision HD Camera type: USB driver: uvcvideo
  bus-ID: 1-5:4 chip-ID: 04f2:b5d6 class-ID: 0e02
  Display: x11 server: X.org compositor: kwin_x11 driver:
  loaded: modesetting unloaded: nvidia resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: Intel Sunrise Point-LP HD Audio vendor: Hewlett-Packard
  driver: snd_hda_intel v: kernel alternate: snd_soc_skl bus-ID: 00:1f.3
  chip-ID: 8086:9d71 class-ID: 0403
  Sound Server-1: ALSA v: k5.10.84-1-lts running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.40 running: no
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
  vendor: Hewlett-Packard driver: r8169 v: kernel port: 3000 bus-ID: 02:00.0
  chip-ID: 10ec:8168 class-ID: 0200
  IF: eno1 state: down mac: <filter>
  Device-2: Intel Wireless 7265 driver: iwlwifi v: kernel bus-ID: 03:00.0
  chip-ID: 8086:095a class-ID: 0280
  IF: wlan0 state: up mac: <filter>
  IF-ID-1: br-05a7dbaaa15a state: up speed: 10000 Mbps duplex: unknown
  mac: <filter>
  IF-ID-2: docker0 state: down mac: <filter>
  IF-ID-3: veth8d125b8 state: up speed: 10000 Mbps duplex: full mac: <filter>
  IF-ID-4: vethd9de22e state: up speed: 10000 Mbps duplex: full mac: <filter>
  IF-ID-5: vethe717f62 state: up speed: 10000 Mbps duplex: full mac: <filter>
  IF-ID-6: wgpia0 state: unknown speed: N/A duplex: N/A mac: N/A
  Device-1: Intel Bluetooth wireless interface type: USB driver: btusb v: 0.8
  bus-ID: 1-4:3 chip-ID: 8087:0a2a class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 2 state: up address: see --recommends
  Local Storage: total: 1.36 TiB used: 763.52 GiB (54.6%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST1000LM035-1RK172
  size: 931.51 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
  type: HDD rpm: 5400 serial: <filter> rev: RSM7 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
  model: WDS500G2B0B-00YS70 size: 465.76 GiB block-size: physical: 512 B
  logical: 512 B speed: 6.0 Gb/s type: SSD serial: <filter> rev: 20WD
  scheme: GPT
  ID-1: / raw-size: 465.47 GiB size: 465.47 GiB (100.00%)
  used: 199.42 GiB (42.8%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
  used: 576 KiB (0.2%) fs: vfat dev: /dev/sdb1 maj-min: 8:17
  ID-3: /home raw-size: 465.47 GiB size: 465.47 GiB (100.00%)
  used: 199.42 GiB (42.8%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
  ID-4: /var/log raw-size: 465.47 GiB size: 465.47 GiB (100.00%)
  used: 199.42 GiB (42.8%) fs: btrfs dev: /dev/sdb2 maj-min: 8:18
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 20 GiB used: 0 KiB (0.0%) priority: -2
  file: /swap/swapfile
  System Temperatures: cpu: 29.8 C pch: 40.5 C mobo: 27.8 C
  Fan Speeds (RPM): N/A
  Processes: 274 Uptime: 1h 12m wakeups: 5 Memory: 15.55 GiB
  used: 3.83 GiB (24.6%) Init: systemd v: 249 tool: systemctl Compilers:
  gcc: 11.1.0 Packages: pacman: 1391 lib: 315 Shell: fish v: 3.3.1
  default: Bash v: 5.1.12 running-in: tmux: inxi: 3.3.09

After the problem occurs, you could use the eos-log-tool and select the first journal log (which should be selected by default).
And should the returned URL address here.

Try changing the channel in you router settings.

1 Like


The router is provided by my apartment, and the channel settings are locked. I tried talking to them, and they said I should talk to the cable provider (Cox) and it’s too much hassle honestly. I do have another router, but switching to it results in reduced network speed as then I have to use an old modem. Cox sucks, basically.

IDK, but changing the channel using ifconfig and iwconfig

Disable wlan0
ifconfig wlan0 down

Enable managed mode
iwconfig wlan0 mode managed

For example put channel 8
ifconfig wlan0 up
iwconfig wlan0 channel 8


Automatic mode
ifconfig wlan0 down
iwconfig wlan0 mode monitor
ifconfig wlan0 up

1 Like

I managed to change the channel in settings. Tried a few options. None seem to work. So it probably isn’t a channel issue.