Unable to create a virtual display in xrandr as there are no other outputs

Heya. Im trying to use Deskreen to create a virtual display so i can use it with my old android tablet. When either using virtual-display-linux, or doing it manually with xrandr, it always says ‘Cannot find Output VIRTUAL1’. The suggestion from most is to ‘just use a different output that isnt being used, eg HDMI1’ but when doing xrandr, there is no other outputs, just my integrated display on my laptop.

Screen 0: minimum 16 x 16, current 1920 x 1080, maximum 32767 x 32767
eDP-1 connected primary 1920x1080+0+0 (normal left inverted right x axis y axis) 340mm x 190mm
   1920x1080     59.96*+
   1440x1080     59.99  
   1400x1050     59.98  
   1280x1024     59.89  
   1280x960      59.94  
[...]

My Laptop does have an HDMI Port, but that’s only showing up when its connected.

Screen 0: minimum 16 x 16, current 3280 x 1080, maximum 32767 x 32767
eDP-1 connected primary 1920x1080+1360+0 (normal left inverted right x axis y axis) 340mm x 190mm
   1920x1080     59.96*+
   1440x1080     59.99  
[...]
HDMI-1 connected 1360x768+0+118 (normal left inverted right x axis y axis) 1600mm x 900mm
   1360x768      59.80*+
   1024x768      59.92  
[...]

So is there any way to add VIRTUAL1 do the list in xrandr? Or to make it so that HDMI1 always shows (without using a dummy plug)?
Thanks.
hardware log here https://0x0.st/Xcey.txt

Output of inxi -G would help

According to this https://github.com/dianariyanto/virtual-display-linux it works only on Intel. But there is also a link to solution on Nvidia.

This has so much info:

I believe HDMI plug will be needed, as this is why those plugs were created in first place, no? Otherwise plug would not be needed.

And more read here: https://www.reddit.com/r/linux/comments/l3etrn/i_created_deskreen_this_is_a_desktop_app_that/

Happy experimenting!

i am using intel, and i have checked those sources and they said that using a virtual display adapter (e.g, virtual-display-linux) would be possible.
inxi -G below.

Graphics:
  Device-1: Intel Raptor Lake-P [Iris Xe Graphics] driver: i915 v: kernel
  Device-2: Generic 720p HD Camera driver: uvcvideo type: USB
  Display: wayland server: X.Org v: 24.1 with: Xwayland v: 24.1.0
    compositor: gnome-shell v: 46.2 driver: gpu: i915 resolution: 1920x1080~60Hz
  API: EGL v: 1.5 drivers: iris,swrast
    platforms: wayland,x11,surfaceless,device
  API: OpenGL v: 4.6 compat-v: 4.5 vendor: intel mesa v: 24.1.1-arch1.1
    renderer: Mesa Intel Graphics (RPL-U)

Hmmm. IDK, if this will work with Wayland. I just tried something more simple on my X11 with intel https://unix.stackexchange.com/a/391519 , after which I was not able to login using GUI. Had to drop into text console and remove file.

So I would start from there. If after reboot it will show up with xrandr , than you probably can do more stuff from here:

Just make sure you know hot to login into text console, to remove file in case GUI will not show up.

hmm. i have that file, and there is still no other outputs in xrandr! i guess it may be a hardware problem?

Or: https://www.reddit.com/r/linux_gaming/comments/119njgz/how_could_i_create_a_virtual_monitor_under/

ive put in the drop-in config file and rebooted, and there is still no sign of a second virtual monitor!

Try to test with wlr-randr …xrandr does use xwayland maybe not the best option

always use z option to remove possible leaking of serials:

inxi -Gaz per example…

https://discovery.endeavouros.com/forum-log-tool-options/how-to-include-systemlogs-in-your-post/2021/03/

1 Like

installing wlr-randr and running it gives me this.

compositor doesn't support wlr-output-management-unstable-v1