Unable to connect to school enterprise network, works in linux mint installer

Hello, I am thinking of returning to Endeavour on my laptop, however I am unable to connect to my schools wifi.

The network uses peap and mschapv2, and devices connect without a cert, in the endeavor installer (and the installed system!) when I provide the correct info it will attempt to connect and then endlessly prompt me for the password, out of curiosity I tried in the Linux mint installer and was able to connect first try.

This is my NM config for the network on linux mint, and is the same as the one on endeavour:








A while ago I was able to connect perfectly with my endeavor system until it stopped working giving me the above issue, leading me to just say f it and put windows on in order to do my work.

Any help would be greatly appreciated.
Thank you,

what Desktop are you using?
and what is the network hardware? → inxi -Naz
tried already using LTS Kernel?

checked journal while it fails?
in terminal start watch it:
journalctl -f

My desktop environment is kde, and my network hardware is as follows:

  Device-1: Intel Wi-Fi 6 AX201 driver: iwlwifi v: kernel bus-ID: 00:14.3
    chip-ID: 8086:a0f0 class-ID: 0280

I have been using the latest kernel but have installed lts and will try it, unfortunately it is the weekend and I am not at my school, but I will give it a try while monitoring journalctl on monday and get back with the results.



When trying on both latest and lts kernel, I get the same issue, I put the journalctl here: https://pastebin.com/khTZAt28

When I connected on windows, it asked me if I expected to connect to the network at this location, and if I still wanted to connect, the way it was explained to me by tech, it seemed like on first connect it would download the nessesary certificate to properly connect,

Tech said everything thing was right on how I was connecting and was unsure of the cause, and I was able to connect on mint.

After way too many hours of scouring google, I found a solution!

As mentioned here: https://bbs.archlinux.org/viewtopic.php?pid=2104709#p2104709 I had to edit the SSID.nmconnection file in /etc/NetworkManager/system-connections/ and add phase1-auth-flags=32 under [802-1x]
After doing that and rebooting, presto, it connected right up!

1 Like

Thank you so much for your troubleshooting steps, they pushed me in the right direction!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.