Unable to connect to one WiFi hotspot

My building has a common WiFi hotspot. Since last ~10 days I am unable to access internet (it does for few hours sometimes only) using it with my Endeavour OS. It works well for me on other devices, also on Windows using same laptop.
Even more strange problem is that the internet works well with my mobile hotspot in the Endeavour OS.
Any help in troubleshooting this issue would be appreciated.

Depending on what you’re doing on EnOS, could it possibly be a bandwidth-issue on your common hotspot in the house?

I guess you need to put out some more specific details for anyone here to help troubleshooting this issue.

From EnOS connected to WiFi, please put out here from running the terminal command ip addr and format the pasted text in post editor as preformatted text ( </> symbol) in the post-editor.

Welcome to EnOS forum. @n0noob :enos:

Welcome to EnOS forum. @n0noob :enos:

Thank you @ivanhoe :slight_smile:

could it possibly be a bandwidth-issue on your common hotspot in the house?

Highly unlikely.

I guess you need to put out some more specific details for anyone here to help troubleshooting this issue.

Please let me know whatever is required. I am desperately looking to solve this.

Few details:
Output ofip addr:

1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
       valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host 
       valid_lft forever preferred_lft forever
2: enp2s0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc fq_codel state DOWN group default qlen 1000
    link/ether 3c:7c:3f:1b:12:23 brd ff:ff:ff:ff:ff:ff
3: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP group default qlen 1000
    link/ether 80:30:49:e0:86:5d brd ff:ff:ff:ff:ff:ff
    inet 10.100.126.203/24 brd 10.100.126.255 scope global dynamic noprefixroute wlan0
       valid_lft 10484sec preferred_lft 10484sec
    inet6 2406:7400:63:9cb5:9bc2:1024:c973:daff/64 scope global dynamic noprefixroute 
       valid_lft 299sec preferred_lft 119sec
    inet6 fe80::e1c1:b9f6:6982:1242/64 scope link noprefixroute 
       valid_lft forever preferred_lft forever

Output of cat /etc/resolv.conf:

# Generated by NetworkManager
nameserver 180.151.151.151
nameserver 180.151.151.152
nameserver 8.8.4.4
# NOTE: the libc resolver may not support more than 3 nameservers.
# The nameservers listed below may not be recognized.
nameserver 8.8.8.8

Output of uname -a:

Linux anoop-pc 5.15.64-1-lts #1 SMP Wed, 31 Aug 2022 17:46:31 +0000 x86_64 GNU/Linux

Also, ping www.youtube.com :

ping: www.youtube.com: Temporary failure in name resolution

Ok. - So what are your hardware details, according to inxi -Fzxa as it might potentially be a chipset-driver issue?

Output of inxi -Fzxa:

System:
  Kernel: 5.15.64-1-lts arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: root=UUID=a60fe1b9-278f-4a6a-916e-c50f7f6d8e04 rw quiet
    loglevel=3 nowatchdog nvme_load=YES nvidia-drm.modeset=1
    initrd=boot\initramfs-linux-lts.img
  Desktop: i3 v: 4.20.1 info: polybar vt: 7 dm: LightDM v: 1.32.0
    Distro: EndeavourOS base: Arch Linux
Machine:
  Type: Laptop System: ASUSTeK product: ASUS TUF Gaming A15 FA506II_FA506II
    v: 1.0 serial: <superuser required>
  Mobo: ASUSTeK model: FA506II v: 1.0 serial: <superuser required>
    UEFI: American Megatrends v: FA506II.316 date: 03/12/2021
Battery:
  ID-1: BAT1 charge: 25.0 Wh (63.0%) condition: 39.7/48.2 Wh (82.5%)
    volts: 11.3 min: 11.9 model: ASUS A32-K55 type: Li-ion serial: N/A
    status: discharging
CPU:
  Info: model: AMD Ryzen 7 4800H with Radeon Graphics bits: 64 type: MT MCP
    arch: Zen 2 gen: 3 built: 2020-22 process: TSMC n7 (7nm) family: 0x17 (23)
    model-id: 0x60 (96) stepping: 1 microcode: 0x8600104
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 512 KiB desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB
    L3: 8 MiB desc: 2x4 MiB
  Speed (MHz): avg: 1389 high: 1397 min/max: 1400/2900 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1397 2: 1397
    3: 1397 4: 1397 5: 1397 6: 1397 7: 1397 8: 1275 9: 1397 10: 1397 11: 1397
    12: 1396 13: 1397 14: 1397 15: 1397 16: 1397 bogomips: 92628
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT enabled with STIBP
    protection
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, STIBP:
    always-on, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: NVIDIA TU117M [GeForce GTX 1650 Ti Mobile] vendor: ASUSTeK
    driver: nvidia v: 515.65.01 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-07) arch: Turing code: TUxxx
    process: TSMC 12nm built: 2018-22 pcie: gen: 1 speed: 2.5 GT/s lanes: 8
    link-max: gen: 3 speed: 8 GT/s lanes: 16 ports: active: none empty: DP-1
    bus-ID: 01:00.0 chip-ID: 10de:1f95 class-ID: 0300
  Device-2: AMD Renoir vendor: ASUSTeK driver: amdgpu v: kernel
    arch: GCN-5.1 code: Vega-2 process: TSMC n7 (7nm) built: 2018-21 pcie:
    gen: 4 speed: 16 GT/s lanes: 16 ports: active: eDP-1 empty: HDMI-A-1
    bus-ID: 05:00.0 chip-ID: 1002:1636 class-ID: 0300
  Device-3: IMC Networks USB2.0 HD UVC WebCam type: USB driver: uvcvideo
    bus-ID: 1-4:2 chip-ID: 13d3:56a2 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 compositor: Picom v: git-7e568
    driver: X: loaded: amdgpu,nvidia unloaded: modesetting
    alternate: fbdev,nouveau,nv,vesa gpu: amdgpu display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: eDP-1 mapped: eDP model: Najing CEC Panda 0x004d built: 2019
    res: 1920x1080 hz: 144 dpi: 142 gamma: 1.2 size: 344x194mm (13.54x7.64")
    diag: 395mm (15.5") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  OpenGL: renderer: AMD RENOIR (LLVM 14.0.6 DRM 3.42 5.15.64-1-lts) v: 4.6
    Mesa 22.1.7 direct render: Yes
Audio:
  Device-1: NVIDIA vendor: ASUSTeK driver: snd_hda_intel v: kernel pcie:
    gen: 1 speed: 2.5 GT/s lanes: 8 link-max: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 01:00.1 chip-ID: 10de:10fa class-ID: 0403
  Device-2: AMD Renoir Radeon High Definition Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 05:00.1 chip-ID: 1002:1637 class-ID: 0403
  Device-3: AMD ACP/ACP3X/ACP6x Audio Coprocessor driver: N/A
    alternate: snd_pci_acp3x, snd_rn_pci_acp3x, snd_pci_acp5x pcie: gen: 4
    speed: 16 GT/s lanes: 16 bus-ID: 05:00.5 chip-ID: 1022:15e2
    class-ID: 0480
  Device-4: AMD Family 17h/19h HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel pcie: gen: 4 speed: 16 GT/s lanes: 16
    bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.64-1-lts running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.56 running: yes
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: e000 bus-ID: 02:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp2s0 state: down mac: <filter>
  Device-2: Realtek RTL8822CE 802.11ac PCIe Wireless Network Adapter
    vendor: Lite-On driver: rtw_8822ce v: N/A modules: rtw88_8822ce pcie:
    gen: 1 speed: 2.5 GT/s lanes: 1 port: d000 bus-ID: 03:00.0
    chip-ID: 10ec:c822 class-ID: 0280
  IF: wlan0 state: up mac: <filter>
Bluetooth:
  Device-1: Lite-On Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 3-1:2 chip-ID: 04ca:4005 class-ID: e001 serial: <filter>
  Report: bt-adapter ID: hci0 rfk-id: 0 state: up address: <filter>
Drives:
  Local Storage: total: 476.94 GiB used: 107.12 GiB (22.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital model: PC SN530
    SDBPNPZ-512G-1002 size: 476.94 GiB block-size: physical: 512 B
    logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD serial: <filter>
    rev: 21106000 temp: 38.9 C scheme: GPT
Partition:
  ID-1: / raw-size: 50 GiB size: 48.91 GiB (97.83%) used: 23.93 GiB (48.9%)
    fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%) used: 29.1 MiB
    (30.3%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  ID-3: /home raw-size: 100 GiB size: 97.87 GiB (97.87%) used: 83.16 GiB
    (85.0%) fs: ext4 dev: /dev/nvme0n1p6 maj-min: 259:6
Swap:
  Alert: No swap data was found.
Sensors:
  System Temperatures: cpu: 40.4 C mobo: N/A gpu: amdgpu temp: 38.0 C
  Fan Speeds (RPM): cpu: 2200
Info:
  Processes: 285 Uptime: 27m wakeups: 1 Memory: 15.05 GiB used: 2.03 GiB
  (13.5%) Init: systemd v: 251 default: graphical tool: systemctl
  Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pacman: 982 lib: 246
  Shell: Bash v: 5.1.16 running-in: xfce4-terminal inxi: 3.3.20

Whatever happened, happened recently. It was working fine earlier. It could be ISP’s fault also, but for me to blame them, I should have a concrete argument.

A web-search for this:

wifi laggy on rtw_8822ce driver

…will provide some answers… maybe not a real solution for Linux, though.
It is a known issue, and the reason behind it seems a chipset, that has Wifi and Bluetooth on one chip.

Can you get a different Wifi card, or USB?

Firstly, I appreciate that you are looking into this.

With the same embedded chip, it always worked, just that recently something happened. Even now it is working flawlessly with my mobile hotspot (different wifi with the same chipset, same driver and same OS).

I even tried downgrading the kernel as well, when this happened. Also, tried using the latest kernel instead of lts, still no luck.

Like I said, you could try various things, as given on the web.
For example, this one, or follow this discussion.

Also you could try to see if the behviour changes, when you shut the laptop completely down and disconnect it from power (incl. battery) for min. 30 seconds. And then reboot it afterwards.

(I do not think it is related to your provider at all, since connecting to your mobile hotspot uses a much smaller wifi bandwidth through your mobile phone, as when compared to a direct wifi connection with the provider from your house. - Like I said, it is a well known issue in the Linux world with this wifi-chip.)

Lastly, looking if there was an update to the wifi driver in your logs, 8-12 days ago and if yes downgrade the driver.

Good luck!

1 Like

The IP address for youtube is:
142.250.114.93

Try
ping 142.250.114.93

If that works and
ping www.youtube.com
does not work, then you have DNS problems in either your computer or the common wifi hotspot.

Pudge

1 Like

I believe I have found the solution.
Possibly it is systemd-resolved service which was disabled (also not running by default). Starting/enabling it solved the issue for me.
I have few follow up questions though, why it possibly got disabled?
Possibly it got disabled with an update. But, then why?
Is it supposed to be disabled?

One guess of mine is you may have tried DNS proxy clients, which require systemd-resolved to be disabled like https://wiki.archlinux.org/title/Dnscrypt-proxy#Disable_any_services_bound_to_port_53

Glad you got it working.

If you consider this Topic as being solved, please do the following.
Go to the post that most helped you solve the problem, or lead you in the right direction.

Go to that post, click on the three horizontal dots, then click on the “Solution” button.
This will mark the Topic as solved and may help someone with a similar problem later.

Pudge

I don’t remember trying DNS proxy clients. I will keep an eye on the daemon, will update here if I find the root cause.

Done.

Thank you EnOS Team! Appreciate the help!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.