[Unable to Connect] message on logon screen

It s curious that I never got this message before the last update. Apparently EOS trying to connect to the internet before I even enter my logon password. My guess is that EOS is trying to connect to the internet before Mulvad is loaded. The kill switch feature is enabled by default now, so no internet until Mullvad starts. By the time the pass is entered, and the desktop loads, the internet is up and running, so it s not a big deal. The message on the logon screen is the only difference now. It s almost like something was too optimized :thinking:

Can you share a picture of that so we can see what you are referring to?

NetworkManager does a connectivity check after it connects to your network: https://wiki.archlinux.org/title/NetworkManager#Checking_connectivity If your killswitch is up, the connectivity check will fail.

Test if this is what is happening by disabling the connectivity check:

To disable NetworkManager’s connectivity check, use the following configuration. This can be useful when connected to a VPN that blocks connectivity checks.