Unable to change desktop environment from KDE Plasma


I installed Endeavour OS with only KDE Plasma but then decided to try xfce so I installed it using the following command:

sudo pacman -S xfce4-goodies

However, after I go to the login screen there is no option to change the DE. When I restart my computer it also doesn’t show anywhere.
When I run xfce4-about I get the following response:

(xfce4-about:8350): Gtk-WARNING **: 13:10:26.239: Content added to the action area of a dialog using header bars

(xfce4-about:8350): Gtk-WARNING **: 13:10:26.240: Content added to the action area of a dialog using header bars
xfce4-about-Message: 13:10:26.311: No vendor information found in "/usr/share/xfce4/vendorinfo".

also the window attached on the screen appears:

How can I change the DE without reinstalling the system?

Thanks in advance

You need to run sudo pacman -S xfce4

But be careful with installing multiple DE. Read this


And also multiple threads on the forum about why be careful.


I already run the command but there is still no option to change the DE. Both when I log out and restart my computer


Top left on basic installation.

Bottom left on the theme I use:

Could be that you need to switch to lightdm but I thought only gnome acts with the login manager and needs gdm instead of sdm. You can switch the login manager using the welcome app or two easy commands on terminal. One to install, and second to activate.

xfce works fine on sddm.

1 Like

Did you try that?

Looking at xfce4-goodies


Looks like just some additional plugins etc.

I don’t know what the issue was but uninstalling xfce and installing it again solved the issue for me. Thanks for help, everyone!

So you had to install this package …? would be useful to know what solved you thread then mark the solution as solved.

It looks like you just installed xfce-goodies. You need to install xfce as per the wiki.


Which I pointed to 3 times, but no one cares what the mandalorian says :rofl:

Same link post # 2

1 Like

Yes i realize you posted it. 3x isn’t always a charm! :laughing:

1 Like