Unable to boot, install and run any live distro at all

I have a new system with the following specifications:

Intel Core i5-12400
Asus Noctua RTX3070 (dual 4k monitors connected through displayport)
32gb memory
2tb nvme ssd

Arch linux shortly ran on this system before. The installation on that disk however was performed on an older system (featuring a gtx750 graphics card). It quickly went south after using it twice or so, it refused to update anything and eventually did not boot anymore. Because it was installed on the disk in another system I figured a fresh installation would be best.

I have not managed to make this happen so far. I have tried many things but the results are the same, not just for endeavour but for any live distribution:
I get past the grub screen, things appear to load but then the signal to the monitors just disappear and turn off.

It probably has something to do with the Nvidia card but no solution seems to work. Tried every setting i have in bios, force onboard graphics, force rtx3070 graphics, load with nvidia drivers, load without, nomodeset, I tried anything google presented.

So far the only thing I actually managed to get on the screen after grub without the monitor signal being killed is this:

grub error

and thats it. It just keeps cycling through this message. I tried doing the same trick as before, install on another system then swap disks but to no avail. Darkness is all I get. Any suggestions?

You need to add ibt=off as a kernel option.

It is an incompatibility with the current Nvidia drivers.


unfortunately this has not worked


well it actually worked, sort of. It did finally help getting the live usb system running, adding ibt=off allowed me to boot that. Then I reinstalled on the disk and this freshly installed OS does actually run without any changes or tricks.