Unable to boot after mesa driver downgrade

I use linux for emulation, but with mesa 20 or higher everything in the games goes black. I have had EndeavourOS running with mesa 19 before and that was completely smooth so i tried to downgrade them, but now i just get a black screen instead of booting. Any way to fix or do i have to reinstall, and if i have to reinstall, how do i downgrade them successfully?

Edit: This was a pretty new install so i don’t mind if i have to reinstall, it would just be a bit faster if i don’t.

Can you switch to a TTY with ctrl+alt+f3 after giving your machine time to boot?(even if the screen is black) If so, login there and upgrade your system again with sudo pacman -Syu


Thanks, this fixed it! :+1:
Is there any way to correctly downgrade them, or does endeavouros just not support it anymore?
I wouldn’t mind running an older version if that is the case.

1 Like

It is rolling so what happens over time is that downgrades to older versions stop working. Since it is rolling, there are no old versions of the system itself.

That being said, I am not sure if that is the case with mesa 19 or not.

1 Like

Well thanks anyways!

As @dalto implied, downgrading is not a solution. It can be a temporary workaround at best, nothing more. And nothing guarantees that it helps at all.

Having said that, there’s e.g. a program downgrade that is able to downgrade packages. It does a good job, but as mentioned above, guarantees nothing.

1 Like

I’ll give it a try. :+1: