Unable to access UEFI settings

Hi everyone,

I’m running endeavour-os on my laptop, Acer Swift 3 SF314-52.

I decided to move from a configuration with ubuntu-windows11 to arch_linux-windows11.
When I was using ubuntu everything was working correctly, I could access to the UEFI setting as it should be.

I just installed endeavour-os instead of ubuntu and the default bootloader is set to the windows one.

First I tried to change the bootloader order using efibootmgr but it’s not working, after rebooting the settings are not saved.
Then I tried to access to the UEFI setting interface but I get just a black screen with a bilking score in the left top corner.
I’m still able to select the grub bootloader by pressing F12 at startup but I have to do it every time I switch on my laptop.

Is there a way to change the default bootloader?
Is there a way to get back the access to UEFI settings?

Thank you

We have seen an inability to get the bios/firmware to honor the boot order when the fallback EFI entry is invalid. The fallback entry is in /boot/efi/EFI/boot/bootx64.efi

Try overwriting that file with your grub EFI entry.

1 Like

Make sure Secure Boot is disabled. Ubuntu can work without it disabled, but not EnOS.

Meanwhile, deep down the rabbit-hole, I:

Secure Boot is disabled

What do you mean? How should I overwrite that file?

Something like:

sudo cp /boot/efi/EFI/endeavouros/grubx64.efi /boot/efi/EFI/boot/bootx64.efi

/boot/efi/EFI/endeavouros might have a slightly different name on your machine.

I tried with this command but UEFI settings are still not available

Can you set the boot order via efibootmgr now?

How are you trying to access the UEFI settings?

I tried to access the UEFI settings by pressing F2 at startup and by selecting “UEFI Firmware settings” in gub menu. Both of them take me to a black screen with a blinking score in the left top corner.

After a few tries, I found that efibootmgr can actually set the boot order but the windows bootloader becomes the first again if:

  • I push the “Restart” button instead of “Power off”.
  • I try to access the UEFI firmware settings (both methods)

That sounds like an issue your hardware/firmware.

When I was in “ubuntu+windows11” configuration everything was working as expected. In the past I tried PopOS and I had the same issue, so I think it could be a configuration issue, or maybe ubuntu is using an older version of some software which is still compatible with my laptop…

Are able to boot directly to uefi with this command?

systemctl reboot --firmware-setup

It takes me to the same black screen

To me it sounds like you have one OS installed in Bios mode? :thinking: Is that a possibility?

Edit: UEFI won’t boot into Bios mode you’ll just get a blank screen.

Edit2: This usually happens if you don’t have CSM disabled. It ends up installing in Bios mode.

Edit3: You can easily check by booting on the live ISO and check the installed system.

The only system I have installed in the past 6 months is Endeavour OS, intalled 4 days ago. Before Enveavour install I was able to access the UEFI settings. I don’t think I have installed endeavour in BIOS mode…

Which command I should run to check that?

Well there are various commands. Try this one.

sudo fdisk -l

Should I run it from the live ISO?

Are you able to boot into EndeavourOS?

Yep, by pressing F12 at startup I can select grub as bootloader