UI far too big

image
As you can see, something is wrong. I haven’t had this issue happen on any of my other systems. I use the Nvidia drivers, if that helps. I’ve looked through many different posts here, on Reddit, and other forums and none of them have been able to give me a straight answer on what exactly to do. Some say you need to edit something called "edid.bin, others say you just need to run these very specific xrandr commands that involve measuring your screen, and others say you only need to adjust the dpi slider in settings. I don’t have a ruler, nor do I think that having one could help anyway, so I’m just lost. Do I just need to deal with it? This really sucks.

EDIT: My laptop is an Acer Predator g9-793 and it runs at 1080p.

Hello @killbotvii
I’m at work right now but I’ll look at this. What is the Hz of your monitor? You say it is 1080p so resolution should be 1920x1080. Not sure of the hz? I think it’s an easy fix. What desktop did you install? What is the exact issue? UI is too big? What do you mean exactly?

Hey there. Sorry for being so vague. The monitor runs at 75hz, I installed KDE Plasma(hence why I’m posting in this board), the exact issue that everything is scaled too large and some elements don’t fit at all. The easiest to notice examples are that the title bars for windows and ESPECIALLY the start menu in the screenshot are way too big.

EDIT: Here’s how everything looks on my desktop so you can have a good comparison:
image

Can we see your settings in:

  • system settings->appearance->fonts
  • system settings->display and monitor->display configuration

The only real customization I’ve made on this machine so far is to change the fonts to the official Apple ones, which I’ve done without problems on all my other systems.
image
image

Try making the Window Title font size a point or two smaller. That should fix the large titlebars.

Is anything else oversized other than the application launcher?

Yes, there are many more things that become apparent when you try to make the slightest bit of customization. Here’s what things look like when you change the global theme to McMojave: image
There is no possible way that this is intended. You can’t even drag from those edges, you have to drag from this invisible spot just off the side of the buttons.

That is a different issue.

Can we see the output of:

env | grep -i qt

Also, are you using wayland or X11?

[killbotvii@killbotvii-gaminglaptop ~]$ env | grep -i qt
QT_SCREEN_SCALE_FACTORS=DP-0=1;DP-1=1;DP-2=1;DP-3=1;HDMI-0=1;DP-4=1;
QT_AUTO_SCREEN_SCALE_FACTOR=0

I’m using X11.

Have you restarted plasma since making all those changes?

It looks like you set a different scale and then changed it back.

Those large window borders in aurorae themes are usually caused by fractional scaling.

I’ve restarted several times, including just now to be safe, and it’s the same output.

on a possibly related note: might your installation be with an existing /HOME partition and saved KDE settings?

Has happened to me.

Not in this case, this is a fresh install with BTRFS as the file system, so the system is one partition.

What is your DPI set at?

1 Like

Still a DPI story !

what happen if you change your DPI resolution then you close appareance windows and come back to your original value ?

Could you give the result of this :

xdpyinfo | grep -B2 resolution

and :

xrdb -query | grep dpi

Nothing new happens when I change the DPI forward and back, it does it larger with higher values, but it never gets smaller than the current size you see. Here’s the results of the commands:

[killbotvii@killbotvii-gaminglaptop ~]$ xdpyinfo | grep -B2 resolution
screen #0:
  dimensions:    1920x1080 pixels (381x211 millimeters)
  resolution:    128x130 dots per inch
[killbotvii@killbotvii-gaminglaptop ~]$ xrdb -query | grep dpi
[killbotvii@killbotvii-gaminglaptop ~]$ 

Yeah, the second one’s output is blank.

What does xrandr show?

Edit" Also did you try uncheck “force font DPI” in plasma settings fonts?
Edit2 This probably has no effect.

Just another question? What video drivers did you install?

Your diagonale screen is about 435.52 mm = 17’ is it true ?

then check here your real DPI with your display values detected to see if it corresponds :

https://www.pxcalc.com/

it gave me the good value 128 DPI so no detection problem !
Capture d’écran_2020-07-22_05-20-28

A GTK App that override your setup or font

1 Like

I will throw my chip in the pool. You said you run nvidia, and I am assuming it is proprietary drivers. Have you tried running ‘nvidia-settings’ as root and creating/saving a new xorg.conf file, then rebooting? I usually have to do this with my 1660 super card along with changing the DPI setting in ‘SDDM’ to get the login screen sized appropriately;

In /etc/sddm.conf:

[X11]
ServerArguments=-nolisten tcp -dpi 96