Ufw refuses to start at boot

Finished rebuilding my system today. One of the last steps was adding ufw and removing firewalld (just used to ufw, that’s all). After configuring rules for SSH and NFS, I made sure that the service was enabled:

sudo ufw enable
sudo systemctl enable ufw.service

I’ve done this on dozens of systems and it’s always worked this way, including my last install before this one. After rebooting, however, I find that my network is completely dead. I had thought it was because of my Windows 10 install screwing with it. But it was because ufw did not start. The service logs show absolutely nothing - it says it’s enabled, but sudo ufw status shows that it’s inactive. I checked /etc/ufw/ufw.conf and it has ENABLED=yes set correctly.

So now if I run sudo systemctl start ufw manually, it runs as expected and now my network is up again. Since I didn’t do anything, I have no idea why this works after I log in but not before.

Hmmm…guess I should have actually removed firewalld, right? :clown_face:

I run this command which never failed me :

sudo systemctl enable --now ufw

Yeah, it works if firewalld has been disabled/removed first.