[UEFI] unable to reinstall grub from chroot

Hello, i freshly installed endeavourOS on my machine and instantly have problem with grub… So i basically configured everything and it worked fine. I used os-prober and overwritten grub.cfg file with gub-mkconfig. It showed Windows and linux so it was perfect.
I have single drive for both windows and endeavouros and made several partitions (root, home, swap).
After installation i switched to windows to test things out, it had some .NET bs update so i rebooted it. I instantly noticed that grub didnt show up, it instantly shipped to windows.
I followed some steps and tried to reinstall grub, but it fails saying that “EFI variables are not supported on this system”… I honestly don’t know what am i doing wrong. Its a fresh install i didnt even have time to break it.
Here are some photos of what’s showing up:
Screenshot_2022-09-30_18-32-38
Screenshot_2022-09-30_18-34-40

Wrong. You broke it with your Windows Update!

Perhaps someone with an UEFI system can help you, as I am on Legacy bios boot.

E_1JA4dVcAclBkN
I just want to enjoy my dualboot without spending whole weekend on fixing problems.

Look here:

https://wiki.archlinux.org/title/chroot

And here:
https://discovery.endeavouros.com/system-rescue/repair-a-non-booting-grub/2021/03/

recheck all options in your UEFI boot :

  • Secureboot desactived
  • no Fast , CSM or Legacy
  • all disk on AHCI

before chroot , check

inxi -Fxza
test -d /sys/firmware/efi && echo efi || echo bios

If you want to enjoy using your computer, get rid of windoze. It’s malware.

6 Likes

Your screenhot says, you’re on Legacy bios, not UEFI. Sorry I missed that.

It’s easy, just follow this guide to arch-chroot:
https://discovery.endeavouros.com/system-rescue/arch-chroot-for-bios-legacy-systems/2021/03/

And then:

Repair GRUB on BIOS systems

If you have more than one operating system installed on your machine, run os-prober first before you proceed. This package will scan all your operating systems installed and put them in GRUB. If you only have EndeavourOS installed go directly to step two.

  1. reinstall GRUB:

grub-install --target=i386-pc /dev/sdX

Remember, the X must be replaced with the letter that is marked in your situation, for instance, /dev/sda

  1. Rebuild grub.cfg configuration file:

grub-mkconfig -o /boot/grub/grub.cfg

Now GRUB is repaired and you should be able to boot into your system again.

Yeah, the problem is that it’s UEFI not Legacy. And it keeps telling me that “EFI variables are not supported on this system”.

Have you enabled legacy-boot in your UEFI bios then? Seems it must be something in the UEFI settings? Did you get the latest update for it yet?

I just downloaded eos again and written it to fresh drive and installed it again. Will see if it happens again. Thanks everyone :slight_smile:

Yeah, the problem is that it’s UEFI not Legacy. And it keeps telling me that “EFI variables are not supported on this system”.

looks like your firmware resets USB boot to use csm/legacy Bios mode so the ISO itself was booted into legacy mode and was not able to recreate UEFI bootloader…

So you’re going to install EndeavourOS every time you have a windoze update? :rofl:

2 Likes

Gotta keep that clean fresh feeling.

It’s addictive and I’m never satisfied with how many times I do it.
:blush:

Time to move windows into a VM on an external drive. Then it can’t mess with a natively installed linux. :wink:

1 Like

You will. You’re not even thru your first year yet hahaha.

Testing the images I make is part of my job here
:stuck_out_tongue_winking_eye:

My development machine has been rock solid for around 4 months now. I don’t plan on messing with it.

Again, you’re still fresh. Thanks for all your help.

I don’t understand how so many people have issues with dual boot with Windows. I have multiple computers with dual boot Windows and EndeavourOS or Arch and my updating never causes this. I’m not sure how users are doing their dual boot installs or how they are updating but this makes no sense to me. Sure i understand the grub issue but Windows update ruining grub? I just don’t get that on mine.
If CSM is enabled one is looking for problems.