Uefi firmware won't load

I did a fresh install and everything seemed fine but when I tried to access the menu to change boot priorities it only displayed Acer logo and stayed stuck on that. I have Windows installed on another M2 disk that did not show up during installation. Secure and Fast boot were disabled before I lost access to the menu, also uninstalling EndeavourOS solves the issue but that’s not very ideal solution

welcome here and sorry to see your issue…
Is the boot method set to UEFI also? Some Firmware are set to boot in legacy mode per default if you boot from USB so it could be that installation was done in legacy mode not UEFI because installer was booting like that.

Welcome to the forum @kedar :balloon::tada:

is there any way to check ? I think that during install it said something along the lines of mounting /efi and when running efibootmgr it shows the boot order

this is the way to check :wink: it would give that there is no efi available …
And windows is also installed in UEFI mode?

It is very unlikely that installing EndeavourOS will mess with the Bios/Firmware… it is only adding an boot entry into the bootmanager section…
Do you use automatic partitioning? and added a new EFI/ESP partition or using the one from Windows?

not sure about windows it came preinstalled with the laptop. I am also unsure if there was nothing wrong with the disk partitioning process cause it left a bit of unassigned space. Also tried wiping the disk on which I have EndeavourOS installed and somehow that helped

could be also one of these devices with raid system?

might be cause I remember when I first started using linux I was unable to install ubuntu due to some setting that I could not turn off but after that I was able to get arch working

And i do understand right that you can not boot EndeavourOS at all?
installer log and boot log would say more than 100 words :wink:
installer log will be saved into installed system under /var/log/endeavour-install.log

I can boot into it by manually selecting it through f12 menu, the only thing that does not work is UEFI Firmware

by UEFI firmware you mean the system Bios/firmware ?

yes, basically after pressing f2 or using the grub option to go there I am stuck on Acer logo

strange issue… as usually also if you uninstall any OS the boot entry in firmware will stay there and no changes will be applied aside from that.

would you mind to post some specs and boot log?
So I could do some investigation…
inxi -Fxxc0z --no-host >> log.txt && journalctl -b -0 >> log.txt && cat log.txt | eos-sendlog

Yes absolutely, not sure how to use that command you posted though

copy paste it into terminal, and it will write systemspecs and bootlog into a file, send it to pastebin and gives you a short URL to the pastebin :wink:

ok so this is what you need right ? https://clbin.com/Le4LD

also not sure if it is relevant but I just noticed that I have two options for booting into linux from f12 menu 1. EndeavourOS and 2. has some weird name

exactly :wink:

Machine:   Type: Laptop System: Acer product: Aspire A515-55 v: V1.08 serial: <filter> 
           Mobo: IL model: Doc_IL v: V1.08 serial: <filter> UEFI: Insyde v: 1.08 date: 05/27/2020 

acer has Firmware update (1.12) … could help in some cases…

I do not see any errors there… only warnings (as usual a lot of them if running plasma) you should check your GTK theming settings may have a lot gtk themes installed?

show it :wink: