Typing headaches

For some time now, I’m having this odd and frustrating problem.
Every time I’m typing text and I need a capital letter, very often, not always, the text gets erased or the text I’m typing suddenly continues on the place the cursor is.
You can imagine that when I’m typing a large text, this is very frustrating. I can get it back, but it is very annoying.
I don’t type blind, so sometimes it takes a bit more time before I notice it.

This happens on every format I use, so, the forum, WordPress, email, Telegram (desktop version), the terminal and Libreoffice.

I’m using Gnome and it occurs on all my hardware, (Two Thinkpads, an Acer Aspire and a recently bought Lenovo Ideapad (the new Ryzen, and it is really fast, but that is for another thread.) Does anyone have an idea of what is happening? I’ve tried settings and a search didn’t come up with anything.

Have you checked the keyboard shortcut settings?
It sounds like you’re triggering one.

Btw no, I haven’t had that experience (Xfce)

Yes, I did and nothing that indicates that behaviour.

1 Like

My experience (!) suggests you should investigate wide fingers! In particular, on my Amiga I used to have a keyboard ‘wedge’ that intercepted and ignored certain multi-key combinations…as protection against furry keyboard assistants. Not enough low-level knowledge to duplicate it on Intel, though.

On a more serious note, does your keyboard boast n-key rollover?

I have no idea, I’m talking about laptop keyboards, so I suppose they have it.

I have to go so slowly on laptops that I rarely have trouble - except if I didn’t turn off the touchpad. Not going to be able to help on this one! :grin:

1 Like

Are you sure you didn’t pass in Insert mode ?
If yes look after INS or INSERT key and try to play with to see…

No, the insert key isn’t near the left shift key or near a letter key.
To be exact, the insert key is on the top right of the keyboard next to the F12 key

is there any touchscreen nearby ?

I have a somewhat similar problem with a laptop. Also a related problem with my iPad, because its on-screen keyboard layout is really weird.

Do you happen to have any common hardware (like a mouse?) in use with all of the machines?

If you disable the touchpad or a mouse on a laptop, does it help anything?

1 Like

Dont think it is Gnome as I use that and basically most of the programs you mentioned and cannot replicate that error…

1 Like

Stinks like Insert key was pressed. It switches to classic to rewrite / insert mode and shows what you’re facing.

EDIT: I said nothing! :innocent:

1 Like

I will try that and the last time I used a mouse was in 2001 :grinning: :grinning:

@ringo There’s no touchscreen.

In most editors, when you hit the Insert key, the prompt changes between a symbol like a pipe symbol | and a box symbol. The pipe symbol | is what you want.


1 Like

That’s it!! that’s the key that is next to the left shift key!!! Thank you, mystery solved!!!

1 Like

I’m more than just a pretty face, eh. :nerd_face:



The Insert key Insert (often abbreviated Ins ) is a key commonly found on computer keyboards.

It is primarily used to switch between the two text-entering modes on a personal computer (PC) or word processor:

  • overtype mode, in which the cursor, when typing, overwrites any text that is present in the current location; and
  • insert mode, where the cursor inserts a character at its current position, forcing all characters past it one position further.

The insert/overtype mode toggling is not global for the computer or even for a single application but rather local to the text input window in which the Insert key was pressed.

source: https://en.m.wikipedia.org/wiki/Insert_key

i think i was cstched by this before also​:thinking:


@Bryanpwo I have issues with this on v-box. It puts entries in and doesn’t stop like the keys stuck.