Two unrelated boot issues (1. sometimes stuck on bios 2. cant boot nvidia card)

I have two boot issues that started at different times

  1. When I boot, around 50% of the time I get stuck on my bios splash screen. Thankfully getting past this is just a matter of trying to boot again until booting goes through.

I suspect this is not a hardware issue, as it has never happened so far when I’m booting a live usb. Granted, maybe the ssd is the issue (although its less than 2 years old)

  1. I’m currently on ryzen integrated graphics, but I recently bought a cheap gtx1060 and have confirmed it works fine in a live usb environment. However, when I try to boot my existing endeavour install with it, a bit after the bios I get stuck on a black screen.

At first I suspected this happened because nvidia drivers aren’t installed, but AFAIK endeavour should still at least be able to boot first before installing nvidia drivers.

I might be able to solve the second issue on my own with enough trial and error, but I’m worried about the first issue and needing to do a fresh install anyway because of it.


This happens even on Virtualbox, I suspect something UEFI/systemd-boot related, since for me it only happens when using UEFI with systemd-boot.

1 Like

The age of a device has nothing to do with its shape or not. Things like drives and memory fall into what is known as thresholds. This means that the OEM test the device if it passes the test then it gets sent down the line if not then its run back through. So all a device has to do is pass the basic state of test this has no say in the quality of the device.

this could be something with the bios itself. Once you put in the new card it may turn off the internal gpu so you not having drivers installed will prevent it from booting.

True. In my opinion Its still definitely not the most likely possibility for several reasons, just wanted to mention it to be exhaustive.

This nvidia installing utility expects you to already have a card slotted in before using it, which means I should be at least able to run endeavour in terminal even if there aren’t any drivers. Maybe I could try something like that.

Also, when I tried it even the basic endeavour live usb (not the one with nvidia drivers preinstalled) could still show the desktop on my nvidia gpu. But maybe live usbs are different.

But yeah im guessing the second issue would be fixed with a reinstall, its the first one im more concerned about.

that is because if you don’t choose the proprietary then the iso will load up noeveua or however you spell it.

What I am saying is that having plugged in the New card could have switched a bios setting that turns of the internal gpu that is why you should boot back to the live usb chroot then mount the installed system and then update and install the nvidia drivers.

1 Like

I see, makes sense.

Did this start when you put the nvidia card in?

No, it’s an older issue I was planning to ask about for a while, the new card just gave me the impetus to finally make a forum post.

1 Like

I tried the chroot method. Nvidia-inst told me that my gpu (gtx1060) isn’t officially supported so I needed to instead get my driver from the AUR and gave me the package name (nvidia-beta-dkms). Since I knew the exact package, I reasoned I could install the exact package directly from my live OS (no chroot) without my gpu plugged in.

This has bricked my install, at this point I’ll be better off reinstalling from scratch. Thankfully I didn’t have that much important data in there, moving my steam games folder should be easy, only thing I’m worried about would be how to cleanly recover my firefox tabs.

EDIT: there does seem to be something wrong with my ssd now :confused:
EDIT2: Managed to back up my data on another drive, at least