Two systems lost network connectivity

In the last couple days my two systems running endeavour have both lost the ability to access the web. Both systems are running GNOME, I’ve tried both wired and wifi connections, reset router several times ect. I can access my router’s admin login page my typing but no web access.

I am typing this from my laptop running Fedora that is completely unaffected.

Has anyone else noticed issues due to a recent update or anything?

Try ping If it works, it is probably a DNS issue. If it fails, it may be your default gateway setting or some other routing issue.

Thanks for the reply. That did work. DNS issue I guess. Would you mind getting me pointed in the right direction about how I might be able to troubleshoot that?

Take a look in network manager and ensure that you are not overriding the DNS settings.

Also, are you using a VPN client at all? Sometimes those break DNS resolution.

Lastly, check the contents of /etc/resolv.conf

Oh yeah… I was using a VPN with both and it seemed to coincide with the issue in both cases. The contents of /ect/resolv.conf are the same on both machines:

 Generated by NetworkManager
nameserver ::1

I don’t see anything in the GNOME settings about DNS settings. Is that where you meant or is there a seperate network manager settings I should be referring to?

Yeah, that looks pretty broken.

lmao… yeah I’ve just now found that turning the VPN back on restores connectivity. Is this as simple as fixing /ect/resolv.confor does this go deeper than that?

It is probably just a matter of fixing resolv.conf and using a better vpn client.

Check that you have not accidentally left the VPN killswitch enabled. They typically stay on even if you shut down the VPN.

I manually edited /ect/resolv.conf with the below contents and that seems to have fixed it.


Thanks for the help. I use ProtonVPN maybe I’ll look into another one.

I’ll look into the killswitch as well.

Thanks all!

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.