Tuxedo control center on EOS

Hi all,

I got new laptop 2 days ago. I tried to install eos first , but messed up something while I tried to install TCC- tuxedo control center.

link is here, I followed that but nothing happened.

Now I installed fresh EOS, and need help :slight_smile: can someone guide me,hehe

Can you share the output of:

yay -Syu tuxedo-keyboard-ite-dkms tuxedo-keyboard-dkms tuxedo-control-center-bin
1 Like
[markob@tuxpro ~]$ yay -Syu tuxedo-keyboard-ite-dkms tuxedo-keyboard-dkms tuxedo-control-center-bin

[sudo] password for markob: 
:: Synchronizing package databases...
 endeavouros is up to date
 core is up to date
 extra                    1744,4 KiB  5,27 MiB/s 00:00 [-----------------------------] 100%
 community                   7,2 MiB  11,6 MiB/s 00:01 [-----------------------------] 100%
 multilib                  165,1 KiB  1058 KiB/s 00:00 [-----------------------------] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Package (1)       Old Version  New Version  Net Change  Download Size

extra/fontconfig  2:2.14.1-2   2:2.14.2-1     0,01 MiB       0,36 MiB

Total Download Size:   0,36 MiB
Total Installed Size:  1,09 MiB
Net Upgrade Size:      0,01 MiB

:: Proceed with installation? [Y/n]

Is that all of it?

Did you choose ‘Y’?

1 Like
:: Proceed with installation? [Y/n] y
:: Retrieving packages...
 fontconfig-2:2.14.2-...   368,0 KiB  2011 KiB/s 00:00 [-----------------------------] 100%
(1/1) checking keys in keyring                         [-----------------------------] 100%
(1/1) checking package integrity                       [-----------------------------] 100%
(1/1) loading package files                            [-----------------------------] 100%
(1/1) checking for file conflicts                      [-----------------------------] 100%
:: Processing package changes...
(1/1) upgrading fontconfig                             [-----------------------------] 100%
Rebuilding fontconfig cache...
:: Running post-transaction hooks...
(1/3) Arming ConditionNeedsUpdate...
(2/3) Updating fontconfig cache...
(3/3) Checking which packages need to be rebuilt
:: Searching databases for updates...
:: Searching AUR for updates...
:: Checking for conflicts...
:: Checking for inner conflicts...
[Repo:1]  dkms-3.0.10-1
[Aur:2]  tuxedo-keyboard-ite-dkms-0.2.5-1  tuxedo-control-center-bin-1.2.4-1
[Aur Make:1]  tuxedo-keyboard-dkms-3.1.3-1

:: Remove make dependencies after install? [y/N]

OK, pick whatever you prefer there. It shouldn’t have an impact on the install.

1 Like

:: (1/3) Downloaded PKGBUILD: tuxedo-keyboard-ite-dkms
:: (2/3) Downloaded PKGBUILD: tuxedo-keyboard-dkms
:: (3/3) Downloaded PKGBUILD: tuxedo-control-center-bin
3 tuxedo-keyboard-dkms (Build Files Exist)
2 tuxedo-keyboard-ite-dkms (Build Files Exist)
1 tuxedo-control-center-bin (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)

It is up to you if you want to review the diffs or not.

If you don’t, you can choose N

1 Like

ok, it is installed. I opened Control center , but no cpu temp and fan.

Did all the dkms modules load properly? You didn’t show the output for that part.

1 Like

Yes, it loads properly. I tried to turn off my laptop, because I saw that trick on reddit :slight_smile: now it is ok

1 Like

@dalto thanks for your help. Your guide is much easier ,only one command :slight_smile:

1 Like

Nice to see you finally got the laptop. Is it all you expected? What desktop did you end up installing?

1 Like

Yes, it is :slight_smile: I like it so far. Will share later some review with photos.

Atm I am experimenting with the distros.

Defaukt one, Tuxedo os is ok, but just that, ok. Boring stable and it is ubuntu :slight_smile:

Than I tried few more, atm on Vanilla os ,but have weird bugs, like only 49 hz refresh rate, not 90 .

So thinking about Eos and Fedora to stay on .
Eos is the best ofc, best and instant support, Fedora is also great but only what bother me there that Tuxedo control center is not maintained for Fedora always

So probably it should be Eos, with Gnome and maybe btrfs :slight_smile:

Why Gnome? I run btrfs with btrfs-assistant and snapper-support on KDE of course. That way i just install it and i don’t have to configure it all myself. I don’t really have a very large grasp on all things btrfs but it works well and i don’t seem to have any issues. I do reinstall often as i am messing around so much with this and that. It’s all fun & games until i get tired of it. I use what works and don’t use what doesn’t or is a pain to set up to try to make it work. I’m not one for trying to customize everything. I just like things that work and work properly.

Edit: Sure i can install Arch but it’s a pain. Not the install but just not knowing what packages i need or don’t in order for it to work on any particular desktop. EndeavourOS works out of the box and I’m familiar with most of it.

1 Like

Because it is less bloated :crazy_face:

KDE has lot of apps . But yeah, I will switch to kde. It better behave with my laptop resolution.

Ok, I am back to KDE.
But with ext4. not yet fully familiar with btrfs, and dont know how to prepare it for installation and after :slight_smile:

1 Like

I just noticed that feature to optimize charging doesnt work. I set stationary use, but my laptop charged to 100%.

any clue ?

I don’t find KDE bloated. I have installed different versions and the Arch version has a few more things in status and notifications than EOS. I really like KDE because it’s so responsive and fluid for me using it compared to other desktops. As i say i don’t customize the crap out of everything i just install it and make very minor changes and use it. No issues! I also like Xfce Cinnamon and i3 if i was a WM user. Gnome is good too but i don’t prefer it compared to others.